From 0dfa2c84c21ed47f380328861e893d2a9879426d Mon Sep 17 00:00:00 2001
From: Roland McGrath <roland@gnu.org>
Date: Mon, 13 Sep 1999 04:34:38 +0000
Subject: 1999-09-09  Roland McGrath  <roland@baalperazim.frob.com>

	* Makeconf (link-executable): New variable, partial linking
	commands for executables.
	($(target)): Use it.  Move .o's before -Wl,-(, just cause.
	($(addsuffix .static,$(target))): New static pattern rule,
	use `$(link-executable) -static' and static hurd libs.
	[$(doinst) = one]: Give deps to $(target).static too.
	{"Decode makemode" page}: Set linktarg instead of cleantarg for each
	makemode that sets only one.
	[$(makemode) != library]: Append $(linktarg:=.static) to linktarg.
	[$(cleantarg) empty]: Set cleantarg to $(linktarg).
	[Installation section] (targets): Set to $(target) if empty.
	(installable): New variable, union of $(linktarg) and $(targets).
	Remove conditionals on $(doinst), leaving only multi-target version.
	Use $(installable) rather than $(targets) to compute list of
	targets for static pattern rule that does the install.
	(install-targets): New variable, $(targets) plus subset of $(linktarg)
	matching $(build-static:=.static).
	(all): Depend on $(install-targets) rather than $(targets).
	(install): Likewise for computed list of targets in $(installationdir).
	* config.make.in (build-static): New variable.
	* configure.in: Support --enable-static-progs=LIST.
---
 configure.in | 19 ++++++++++++++++---
 1 file changed, 16 insertions(+), 3 deletions(-)

(limited to 'configure.in')

diff --git a/configure.in b/configure.in
index f291b665..91420edc 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
 dnl Process this file with autoconf to produce a configure script.
-AC_REVISION([$Id: configure.in,v 1.15 1999/01/27 20:48:21 roland Exp $])
+AC_REVISION([$Id: configure.in,v 1.16 1999/09/13 04:34:38 roland Exp $])
 AC_PREREQ(2.12)			dnl Minimum Autoconf version required.
 AC_INIT(hurd/hurd_types.h)	dnl A distinctive file to look for in srcdir.
 
@@ -26,10 +26,23 @@ esac
 AC_SUBST(asm_syntax)
 
 AC_ARG_ENABLE(profile,
-[  --disable-profile	  do not build profiled libraries and programs],,
-	      enable_profile=yes)
+[  --disable-profile	  do not build profiled libraries and programs])
 AC_SUBST(enable_profile)
 
+define([default_static],['ext2fs,ufs'])dnl
+AC_ARG_ENABLE(static-progs,
+[  --enable-static-progs=PROGRAMS...
+                          build statically-linked PROGRAM.static versions
+                          of (only) the listed programs ]dnl
+changequote(',')[default_static]changequote([,]))
+case "$enable_static_progs" in
+'no')	enable_static_progs= ;;		# we got --disable-static
+'')	enable_static_progs=default_static ;;
+*)	enable_static_progs=`echo "$enable_static_progs" |
+			     sed 's/[[, ]][[, ]]*/ /g'` ;;
+esac
+AC_SUBST(enable_static_progs)
+
 AC_PROG_INSTALL
 AC_PROG_AWK
 
-- 
cgit v1.2.3