diff options
author | Steve Langasek <vorlon@debian.org> | 2007-09-03 21:45:04 +0000 |
---|---|---|
committer | Steve Langasek <vorlon@debian.org> | 2007-09-03 21:45:04 +0000 |
commit | 379e1f36401db2137b55382a3ad544069279e93d (patch) | |
tree | 6a2cc56f18d2cf6d8fda32cb47879d8c1f409abe | |
parent | caab44a1ddb860fda17df611ae989b8466685ec6 (diff) | |
download | pam-379e1f36401db2137b55382a3ad544069279e93d.tar.gz pam-379e1f36401db2137b55382a3ad544069279e93d.tar.bz2 pam-379e1f36401db2137b55382a3ad544069279e93d.zip |
Relevant BUGIDs: Debian bug #1708
Purpose of commit: cleanup (behavior change)
Commit summary:
---------------
2007-09-03 Steve Langasek <vorlon@debian.org>
* libpam_misc/misc_conv.c: don't block SIGINT in misc_conv; it's
perfectly valid to allow the user to interrupt at a prompt. If
an application wants prompts to not be interruptable, the
application should take responsibility for blocking SIGINT.
-rw-r--r-- | ChangeLog | 7 | ||||
-rw-r--r-- | NEWS | 2 | ||||
-rw-r--r-- | libpam_misc/misc_conv.c | 3 |
3 files changed, 10 insertions, 2 deletions
@@ -1,3 +1,10 @@ +2007-09-03 Steve Langasek <vorlon@debian.org> + + * libpam_misc/misc_conv.c: don't block SIGINT in misc_conv; it's + perfectly valid to allow the user to interrupt at a prompt. If + an application wants prompts to not be interruptable, the + application should take responsibility for blocking SIGINT. + 2007-09-02 Thorsten Kukuk <kukuk@thkukuk.de> * examples/Makefile.am: Fix usage of LIBADD, LDADD and LDFLAGS. @@ -1,5 +1,7 @@ Linux-PAM NEWS -- history of user-visible changes. +* misc_conv no longer blocks SIGINT; applications that don't want + user-interruptable prompts should block SIGINT themselves. Release 0.99.8.1 * Fix a regression in audit code introduced with last release diff --git a/libpam_misc/misc_conv.c b/libpam_misc/misc_conv.c index 8db24d74..3f82de1b 100644 --- a/libpam_misc/misc_conv.c +++ b/libpam_misc/misc_conv.c @@ -150,12 +150,11 @@ static int read_string(int echo, const char *prompt, char **retstr) have_term = 1; /* - * We make a simple attempt to block TTY signals from terminating + * We make a simple attempt to block TTY signals from suspending * the conversation without giving PAM a chance to clean up. */ sigemptyset(&nset); - sigaddset(&nset, SIGINT); sigaddset(&nset, SIGTSTP); (void) sigprocmask(SIG_BLOCK, &nset, &oset); |