diff options
author | Andrew G. Morgan <morgan@kernel.org> | 2002-05-29 04:51:07 +0000 |
---|---|---|
committer | Andrew G. Morgan <morgan@kernel.org> | 2002-05-29 04:51:07 +0000 |
commit | b1a0e87831c3f580963f53cea34cd4c7047eaeac (patch) | |
tree | 4918255e75f465489604f63dadd07ab702cc6c69 | |
parent | 3468d2d4c1a46692d11f223ccbbb5fee665351ac (diff) | |
download | pam-b1a0e87831c3f580963f53cea34cd4c7047eaeac.tar.gz pam-b1a0e87831c3f580963f53cea34cd4c7047eaeac.tar.bz2 pam-b1a0e87831c3f580963f53cea34cd4c7047eaeac.zip |
Relevant BUGIDs: 490938, 409852
Purpose of commit: debugging
Commit summary:
---------------
Added a simple wrapper to make it easier to test xsh with the sandbox
libraries (no help with modules - besides editing your personal pam.d/xsh
file).
-rw-r--r-- | CHANGELOG | 10 | ||||
-rwxr-xr-x | examples/wrap_xsh.sh | 5 |
2 files changed, 11 insertions, 4 deletions
@@ -108,9 +108,10 @@ bug report - outstanding bugs are listed here: This is entirely inapropriate as it overrides PAM_USER_PROMPT. (Bug 486361 - agmorgan). * added a static module helper library object includes a few changes - to examples/xsh.c for testing purposes, and also modified the - pam_rhosts_auth module to use this new library. (Bug 490938, - 409852 - agmorgan) + to examples/xsh.c for testing purposes (added a simple shell wrapper + for running xsh with the sandbox libraries), and also modified the + pam_rhosts_auth module to use this new library. (Bug 490938, 409852 + - agmorgan). * pam_unix: fix 'likeauth' to kill off the memory leak once and for all. (Bug 483959 - vorlon) * pam_unix: restore handling of 'likeauth' argument to a known working @@ -160,7 +161,8 @@ bug report - outstanding bugs are listed here: * verified that the setcred stack didn't suffer from the bug I was nervous about, add a new module pam_debug to help me test this. fixed a libpam/pam_dispatch.c instrumentation line that I tripped - over when testing. (Bug 424315 - agmorgan) + over when testing. Also restructured pam_warn to help here (Bug + 424315 - agmorgan). * pam_unix/support.c: sample use of reentrant NSS function. Not yet active, because modules do not include _pam_aconf_h! (Bug 440107 - vorlon) * doc/Makefile changes - use $(mandir) [courtesy Harald Welte] (Bug diff --git a/examples/wrap_xsh.sh b/examples/wrap_xsh.sh new file mode 100755 index 00000000..af01697e --- /dev/null +++ b/examples/wrap_xsh.sh @@ -0,0 +1,5 @@ +#!/bin/bash +export LD_PRELOAD=../libpam/libpam.so:../libpam_misc/libpam_misc.so +ldd ./xsh +./xsh "$@" + |