diff options
author | Thorsten Kukuk <kukuk@thkukuk.de> | 2010-10-01 11:05:45 +0000 |
---|---|---|
committer | Thorsten Kukuk <kukuk@thkukuk.de> | 2010-10-01 11:05:45 +0000 |
commit | c388a2730d012b5101d264c83f8db586acd3a70c (patch) | |
tree | 5fa237781f017661d53554814a50627ab450eb87 | |
parent | e39126075bf9c8434a9ad4197a4869444afa23cb (diff) | |
download | pam-c388a2730d012b5101d264c83f8db586acd3a70c.tar.gz pam-c388a2730d012b5101d264c83f8db586acd3a70c.tar.bz2 pam-c388a2730d012b5101d264c83f8db586acd3a70c.zip |
Relevant BUGIDs: #3078936
Purpose of commit: bugfix
Commit summary:
---------------
2010-10-01 Thorsten Kukuk <kukuk@thkukuk.de>
* configure.in: Extend cross compiling check.
* doc/specs/Makefile.am: Set CFLAGS and LDFLAGS to BUILD_CFLAGS
and BUILD_LDFLAGS.
Bug #3078936 / gentoo #339174
-rw-r--r-- | ChangeLog | 7 | ||||
-rw-r--r-- | configure.in | 35 | ||||
-rw-r--r-- | doc/specs/Makefile.am | 2 |
3 files changed, 38 insertions, 6 deletions
@@ -1,3 +1,10 @@ +2010-10-01 Thorsten Kukuk <kukuk@thkukuk.de> + + * configure.in: Extend cross compiling check. + * doc/specs/Makefile.am: Set CFLAGS and LDFLAGS to BUILD_CFLAGS + and BUILD_LDFLAGS. + Bug #3078936 / gentoo #339174 + 2010-09-30 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_xauth/pam_xauth.c (pam_sm_close_session): Warn if diff --git a/configure.in b/configure.in index ce844702..76fac05f 100644 --- a/configure.in +++ b/configure.in @@ -86,12 +86,6 @@ AM_PROG_CC_C_O PAM_LD_AS_NEEDED PAM_LD_O1 -if test x"$cross_compiling" = xyes; then - AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc) -else - CC_FOR_BUILD="$CC" -fi - dnl Largefile support AC_SYS_LARGEFILE @@ -134,6 +128,35 @@ if eval "test x$CC = xicc"; then done fi +if test "x${CC_FOR_BUILD+set}" != "xset" ; then + if test "x$cross_compiling" = "xyes" ; then + AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc) + else + CC_FOR_BUILD=${CC} + fi +fi +AC_MSG_CHECKING([for CC_FOR_BUILD]) +AC_MSG_RESULT([$CC_FOR_BUILD]) +AC_SUBST(CC_FOR_BUILD) + +if test "x${BUILD_CFLAGS+set}" != "xset" ; then + if test "x$cross_compiling" = "xyes" ; then + BUILD_CFLAGS= + else + BUILD_CFLAGS=${CFLAGS} + fi +fi +AC_SUBST(BUILD_CFLAGS) + +if test "x${BUILD_LDFLAGS+set}" != "xset" ; then + if test "x$cross_compiling" = "xyes" ; then + BUILD_LDFLAGS= + else + BUILD_LDFLAGS=${LDFLAGS} + fi +fi +AC_SUBST(BUILD_LDFLAGS) + AC_C___ATTRIBUTE__ dnl diff --git a/doc/specs/Makefile.am b/doc/specs/Makefile.am index d92ddd38..26882207 100644 --- a/doc/specs/Makefile.am +++ b/doc/specs/Makefile.am @@ -12,6 +12,8 @@ draft-morgan-pam-current.txt: padout draft-morgan-pam.raw AM_YFLAGS = -d CC = @CC_FOR_BUILD@ +CFLAGS = @BUILD_CFLAGS@ +LDFLAGS = @BUILD_LDFLAGS@ BUILT_SOURCES = parse_y.h |