diff options
author | Steve Langasek <vorlon@debian.org> | 2007-08-29 10:30:11 +0000 |
---|---|---|
committer | Steve Langasek <vorlon@debian.org> | 2007-08-29 10:30:11 +0000 |
commit | d4663ceaeb052c28354afc212da8f25dbc53e969 (patch) | |
tree | 21d2883e1f945ec5fb273e412d2c4c5a6cd9a10a | |
parent | c783f0606e223915b947b564a2f53d2d4ff78d6b (diff) | |
download | pam-d4663ceaeb052c28354afc212da8f25dbc53e969.tar.gz pam-d4663ceaeb052c28354afc212da8f25dbc53e969.tar.bz2 pam-d4663ceaeb052c28354afc212da8f25dbc53e969.zip |
Relevant BUGIDs: Debian bug #440019
Purpose of commit: bugfix
Commit summary:
---------------
2007-08-29 Steve Langasek <vorlon@debian.org>
* modules/pam_rhosts/pam_rhosts_auth.c: getline returns -1 at
EOF, not 0. Check accordingly to fix an infinite loop. Thanks
to Stephan Springl <springl-rhosts@bfw-online.de> for catching
this.
-rw-r--r-- | ChangeLog | 7 | ||||
-rw-r--r-- | modules/pam_rhosts/pam_rhosts_auth.c | 2 |
2 files changed, 8 insertions, 1 deletions
@@ -1,3 +1,10 @@ +2007-08-29 Steve Langasek <vorlon@debian.org> + + * modules/pam_rhosts/pam_rhosts_auth.c: getline returns -1 at + EOF, not 0. Check accordingly to fix an infinite loop. Thanks + to Stephan Springl <springl-rhosts@bfw-online.de> for catching + this. + 2007-08-28 Steve Langasek <vorlon@debian.org> * configure.in: call AC_CHECK_HEADERS instead of AC_CHECK_HEADER diff --git a/modules/pam_rhosts/pam_rhosts_auth.c b/modules/pam_rhosts/pam_rhosts_auth.c index d50ed478..a798c1f0 100644 --- a/modules/pam_rhosts/pam_rhosts_auth.c +++ b/modules/pam_rhosts/pam_rhosts_auth.c @@ -352,7 +352,7 @@ __ivaliduser (pam_handle_t *pamh, struct _options *opts, char *buf=NULL; int buflen=0; - while (getline(&buf,&buflen,hostf)) { + while (getline(&buf,&buflen,hostf) > 0) { #else char buf[MAXHOSTNAMELEN + 128]; /* host + login */ |