aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Schubert <schubi@suse.de>2023-04-06 13:50:37 +0200
committerDmitry V. Levin <ldv@strace.io>2023-04-20 13:10:06 +0000
commita7e4f035fe7b2cb93df9ec38ebe6aa256c2cb8ee (patch)
tree9da2b5e1ab30ed589d8efa5ec533c0eb947a8bb9 /configure.ac
parent4bfb0ce61f7a528287d316b702e4e5d332d95fb7 (diff)
downloadpam-a7e4f035fe7b2cb93df9ec38ebe6aa256c2cb8ee.tar.gz
pam-a7e4f035fe7b2cb93df9ec38ebe6aa256c2cb8ee.tar.bz2
pam-a7e4f035fe7b2cb93df9ec38ebe6aa256c2cb8ee.zip
build: fix --enable-openssl
* Make.xml.rules.in: Avoid conflicting profile.condition settings. * configure.ac: Likewise. Resolves: https://github.com/linux-pam/linux-pam/issues/553
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 10 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index f50484d9..7eae770f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -562,13 +562,15 @@ if test -n "$enable_vendordir"; then
AC_DEFINE_UNQUOTED([VENDOR_SCONFIGDIR], ["$enable_vendordir/security"],
[Directory for PAM modules distribution provided configuration files])
if test "$WITH_ECONF" = "yes" ; then
- STRINGPARAM_VENDORDIR="--stringparam vendordir '$enable_vendordir' --stringparam profile.condition 'with_vendordir;with_vendordir_and_with_econf'"
+ STRINGPARAM_VENDORDIR="--stringparam vendordir '$enable_vendordir'"
+ profileconditions="with_vendordir;with_vendordir_and_with_econf"
else
- STRINGPARAM_VENDORDIR="--stringparam vendordir '$enable_vendordir' --stringparam profile.condition 'with_vendordir;with_vendordir_and_without_econf"
+ STRINGPARAM_VENDORDIR="--stringparam vendordir '$enable_vendordir'"
+ profileconditions="with_vendordir;with_vendordir_and_without_econf"
fi
VENDOR_SCONFIGDIR="$enable_vendordir/security"
else
- STRINGPARAM_VENDORDIR="--stringparam profile.condition 'without_vendordir'"
+ profileconditions="without_vendordir"
fi
AC_SUBST([STRINGPARAM_VENDORDIR])
AC_SUBST(VENDOR_SCONFIGDIR)
@@ -582,14 +584,16 @@ if test "$OPENSSL_ENABLED" = "yes" ; then
[CRYPTO_LIBS="-lcrypto"
use_openssl=yes
AC_DEFINE([WITH_OPENSSL], 1, [OpenSSL provides crypto algorithm for hmac])
- STRINGPARAM_HMAC="--stringparam profile.condition 'openssl_hmac'"],
+ profileconditions+=";openssl_hmac"],
[CRYPTO_LIBS=""
- STRINGPARAM_HMAC="--stringparam profile.condition 'no_openssl_hmac'"])
+ profileconditions+=";no_openssl_hmac"])
fi
AC_SUBST([CRYPTO_LIBS])
-AC_SUBST([STRINGPARAM_HMAC])
AM_CONDITIONAL([COND_USE_OPENSSL], [test "x$use_openssl" = "xyes"])
+STRINGPARAM_PROFILECONDITIONS="--stringparam profile.condition '$profileconditions'"
+AC_SUBST([STRINGPARAM_PROFILECONDITIONS])
+
dnl Checks for header files.
AC_HEADER_DIRENT
AC_HEADER_STDC