aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@strace.io>2023-12-12 08:00:00 +0000
committerDmitry V. Levin <ldv@strace.io>2023-12-12 20:05:08 +0000
commitcf492d0cedf10d4128c5cf211998dff2260acb6a (patch)
tree8ba1eb14c454e6e24cf48e8dd5da22a0c3ce485c /configure.ac
parentf6a171e5c7bcb7c0bf56ea0dc81e3b6843670fc4 (diff)
downloadpam-cf492d0cedf10d4128c5cf211998dff2260acb6a.tar.gz
pam-cf492d0cedf10d4128c5cf211998dff2260acb6a.tar.bz2
pam-cf492d0cedf10d4128c5cf211998dff2260acb6a.zip
treewide: assume getline exists
Apparently, getline is being used unconditionally in pam_namespace and pam_sepermit. In pam_namespace, it is being used since 2006 when the module was introduced in the first place. Let's assume getline is universally available and let's use it unconditionally in other cases, too. * configure.ac (AC_CHECK_FUNCS): Remove getline and getdelim. * libpam/pam_modutil_searchkey.c (pam_modutil_search_key): Use getline unconditionally. * modules/pam_pwhistory/opasswd.c (check_old_pass, save_old_pass): Likewise. * modules/pam_shells/pam_shells.c (perform_check): Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index df95d9bb..cbffa113 100644
--- a/configure.ac
+++ b/configure.ac
@@ -632,7 +632,7 @@ AC_FUNC_VPRINTF
AC_CHECK_FUNCS(fseeko getdomainname gethostname gettimeofday lckpwdf mkdir select)
AC_CHECK_FUNCS(strcspn strdup strspn strstr strtol uname)
AC_CHECK_FUNCS(getutent_r getpwnam_r getpwuid_r getgrnam_r getgrgid_r getspnam_r getmntent_r)
-AC_CHECK_FUNCS(getgrouplist getline getdelim)
+AC_CHECK_FUNCS(getgrouplist)
AC_CHECK_FUNCS(inet_ntop inet_pton innetgr)
AC_CHECK_FUNCS(quotactl)
AC_CHECK_FUNCS(unshare)