aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2020-08-08 08:00:00 +0000
committerDmitry V. Levin <ldv@altlinux.org>2020-08-08 08:00:00 +0000
commite42e178c71c11bb25740a5177eed110ee17b8af2 (patch)
tree0e9fbb8096bfc79e9849ff35bc7a6c27371443e2 /configure.ac
parentd5cb4409ab6b04a6ed7c00245e2c9a430f352b16 (diff)
downloadpam-e42e178c71c11bb25740a5177eed110ee17b8af2.tar.gz
pam-e42e178c71c11bb25740a5177eed110ee17b8af2.tar.bz2
pam-e42e178c71c11bb25740a5177eed110ee17b8af2.zip
configure: add --disable-unix option
Some distributions do not build pam_unix, e.g. ALT uses pam_tcb instead. Add a configure option to disable build of pam_unix so that those who choose not to build pam_unix no longer have to edit modules/Makefile.am file. The default is unchanged, i.e. build of pam_unix is enabled. * configure.ac (AC_ARG_ENABLE): Add unix. (AM_CONDITIONAL): Add COND_BUILD_PAM_UNIX. * modules/Makefile.am [COND_BUILD_PAM_UNIX] (MAYBE_PAM_UNIX): Define. (SUBDIRS): Replace pam_unix with $(COND_BUILD_PAM_UNIX).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 40c1c557..0f2b7de7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -653,6 +653,15 @@ case "$enable_tally2" in
*) AC_MSG_ERROR([bad value $enable_tally2 for --enable-tally2 option]) ;;
esac
+AC_ARG_ENABLE([unix],
+ [AS_HELP_STRING([--disable-unix],
+ [do not build pam_unix module])],
+ [], [enable_unix=yes])
+case "$enable_unix" in
+ yes|no) ;;
+ *) AC_MSG_ERROR([bad value $enable_unix for --enable-unix option]) ;;
+esac
+
AM_CONDITIONAL([COND_BUILD_PAM_CRACKLIB], [test -n "$LIBCRACK"])
AM_CONDITIONAL([COND_BUILD_PAM_KEYINIT], [test "$have_key_syscalls" = 1])
AM_CONDITIONAL([COND_BUILD_PAM_LASTLOG], [test "$ac_cv_func_logwtmp" = yes])
@@ -664,6 +673,7 @@ AM_CONDITIONAL([COND_BUILD_PAM_SETQUOTA], [test "$ac_cv_func_quotactl" = yes])
AM_CONDITIONAL([COND_BUILD_PAM_TALLY], [test "$enable_tally" = yes])
AM_CONDITIONAL([COND_BUILD_PAM_TALLY2], [test "$enable_tally2" = yes])
AM_CONDITIONAL([COND_BUILD_PAM_TTY_AUDIT], [test "$HAVE_AUDIT_TTY_STATUS" = yes])
+AM_CONDITIONAL([COND_BUILD_PAM_UNIX], [test "$enable_unix" = yes])
AM_CONDITIONAL([COND_BUILD_PAM_USERDB], [test -n "$LIBDB"])
dnl Files to be created from when we run configure