aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2010-08-29 00:58:14 -0700
committerSteve Langasek <vorlon@debian.org>2019-01-08 21:26:04 -0800
commit0b7e86d2422eb0ddabce5ffcd59ee31525a4e8af (patch)
tree9f88864e454600c3526c81bd3edc5e5ecdea710c /debian/rules
parente3e0a3d0dfd58a93a85774309564dd3e22f8ee24 (diff)
downloadpam-0b7e86d2422eb0ddabce5ffcd59ee31525a4e8af.tar.gz
pam-0b7e86d2422eb0ddabce5ffcd59ee31525a4e8af.tar.bz2
pam-0b7e86d2422eb0ddabce5ffcd59ee31525a4e8af.zip
debian/rules: pass getconf LFS_CFLAGS so that we get a 64-bit rlimit
interface. Closes: #579402.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index d8cc37ed..b42d70fb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,7 @@
#!/usr/bin/make -f
LDFLAGS := -Wl,-z,defs
-CFLAGS := -g
+CFLAGS := -g $(shell getconf LFS_CFLAGS)
ifeq (,$(findstring noopt, ${DEB_BUILD_OPTIONS}))
CFLAGS += -O2