aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSam Hartman <hartmans@debian.org>2024-02-27 21:25:44 -0700
committerSam Hartman <hartmans@debian.org>2024-02-27 21:25:44 -0700
commit58c5a173ca608476917893e9054cf3d53d0b0744 (patch)
treec5d2ab69a993c150f48f705bff9d76c1139f1e33 /debian/rules
parent80d000dd6637be445a9a0fd930de765cc40352da (diff)
parent56cd5768b32fd97a7156977dcbbd40715e158e9c (diff)
downloadpam-58c5a173ca608476917893e9054cf3d53d0b0744.tar.gz
pam-58c5a173ca608476917893e9054cf3d53d0b0744.tar.bz2
pam-58c5a173ca608476917893e9054cf3d53d0b0744.zip
Merge in 1.5.3 from experimental
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules24
1 files changed, 17 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index 73819f0c..075391ff 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,25 +13,30 @@ DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
LC_COLLATE=C
export LC_COLLATE
-export QUILT_PATCH_DIR = debian/patches-applied
d = $(CURDIR)/debian
dl = $(d)/local
%:
- dh $@ --with quilt,autoreconf
+ dh $@
+
# avoid libaudit-dev when bootstrapping
ifneq (,$(filter stage1,$(DEB_BUILD_PROFILES)))
CONFIGURE_OPTS += --disable-audit
-endif
+endif
+
+CONFIGURE_OPTS += --enable-logind
override_dh_auto_configure:
+ # Explicitly set libdir, sbindir to avoid upstream's override logic.
dh_auto_configure -- --enable-static --enable-shared \
- --libdir=/lib/$(DEB_HOST_MULTIARCH) \
- --enable-isadir=/lib/security \
+ --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
+ --sbindir=/usr/sbin \
+ --enable-isadir=/usr/lib/security \
--with-systemdunitdir=/usr/lib/systemd/system \
--disable-nis \
+ --enable-usergroups \
$(CONFIGURE_OPTS)
# .install files don't have "except for" handling, so we need to exclude
@@ -66,9 +71,14 @@ override_dh_installman:
override_dh_fixperms:
dh_fixperms
ifneq (,$(findstring libpam-modules, $(shell dh_listpackages)))
- chgrp shadow $(d)/libpam-modules-bin/sbin/unix_chkpwd
- chmod 02755 $(d)/libpam-modules-bin/sbin/unix_chkpwd
+ chgrp shadow $(d)/libpam-modules-bin/usr/sbin/unix_chkpwd
+ chmod 02755 $(d)/libpam-modules-bin/usr/sbin/unix_chkpwd
endif
override_dh_installchangelogs:
dh_installchangelogs NEWS
+
+debian/%:debian/%.in
+ sed -e 's/#DEB_HOST_MULTIARCH#/$(DEB_HOST_MULTIARCH)/g' $< > $@
+
+execute_before_dh_installdeb:debian/libpam0t64.preinst debian/libpam0t64.postrm