aboutsummaryrefslogtreecommitdiff
path: root/doc/custom-html.xsl
diff options
context:
space:
mode:
authorStefan Schubert <schubi@suse.de>2022-10-21 16:07:25 +0200
committerDmitry V. Levin <ldv@altlinux.org>2022-10-27 12:12:17 +0000
commit3790bd4aa373187a36e4667873a178ae50f7ecba (patch)
treefabb66078797da5039c7bce92a6184509803af56 /doc/custom-html.xsl
parentf69a6042da801096c94b30465c118e17c803f5c2 (diff)
downloadpam-3790bd4aa373187a36e4667873a178ae50f7ecba.tar.gz
pam-3790bd4aa373187a36e4667873a178ae50f7ecba.tar.bz2
pam-3790bd4aa373187a36e4667873a178ae50f7ecba.zip
doc: make stylesheets configurable
Before this change, all stylesheets were hardcoded. With this change, stylesheets can be defined at configure stage. * configure.ac: Add new options to configure stylesheets: --enable-html-stylesheet=FILE --enable-txt-stylesheet=FILE --enable-pdf-stylesheet=FILE --enable-man-stylesheet=FILE * doc/custom-html.xsl: Rename to doc/custom-html.xsl.in, parametrize html stylesheet. * doc/custom-man.xsl: Rename to doc/custom-man.xsl.in, parametrize man stylesheet. * doc/.gitignore: Add custom-man.xsl and custom-html.xsl. * doc/adg/Makefile.am: Use stylesheet variables. * doc/mwg/Makefile.am: Likewise. * doc/sag/Makefile.am: Likewise. Resolves: https://github.com/linux-pam/linux-pam/pull/499
Diffstat (limited to 'doc/custom-html.xsl')
-rw-r--r--doc/custom-html.xsl18
1 files changed, 0 insertions, 18 deletions
diff --git a/doc/custom-html.xsl b/doc/custom-html.xsl
deleted file mode 100644
index fdd5df7d..00000000
--- a/doc/custom-html.xsl
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version='1.0'?> <!--*-nxml-*-->
-<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
- xmlns:ss="http://docbook.sf.net/xmlns/string.subst/1.0"
- xmlns:exsl="http://exslt.org/common" version="1.0">
-
- <xsl:import href="http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl"/>
- <xsl:param name="vendordir"/>
-
- <xsl:template match="filename">
- <xsl:variable name="replacements">
- <ss:substitution oldstring="%vendordir%" newstring="{$vendordir}" />
- </xsl:variable>
- <xsl:call-template name="apply-string-subst-map">
- <xsl:with-param name="content" select="."/>
- <xsl:with-param name="map.contents" select="exsl:node-set($replacements)/*" />
- </xsl:call-template>
- </xsl:template>
-</xsl:stylesheet>