aboutsummaryrefslogtreecommitdiff
path: root/libpam/Makefile.am
diff options
context:
space:
mode:
authorTobias Stoeckmann <tobias@stoeckmann.org>2024-01-31 20:12:58 +0100
committerDmitry V. Levin <ldv@strace.io>2024-02-06 08:00:00 +0000
commit644dc6f0c15bccc7401e47785753e9c8d01018d3 (patch)
tree32afca676f02af3385fbd5feec7b43899358d3e7 /libpam/Makefile.am
parent9fa68ae79c213026d9621d6a70defb381e5a0533 (diff)
downloadpam-644dc6f0c15bccc7401e47785753e9c8d01018d3.tar.gz
pam-644dc6f0c15bccc7401e47785753e9c8d01018d3.tar.bz2
pam-644dc6f0c15bccc7401e47785753e9c8d01018d3.zip
libpam_internal: introduce pam_line
The pam_assemble_line function is renamed to pam_line_assemble and moved into libpam_internal so it can be shared across libpam and the pam_env module. Applied renaming to all other relevant functions and data structures so it is easier to locate them in files. Signed-off-by: Tobias Stoeckmann <tobias@stoeckmann.org>
Diffstat (limited to 'libpam/Makefile.am')
-rw-r--r--libpam/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libpam/Makefile.am b/libpam/Makefile.am
index e3f4a3bc..505900b5 100644
--- a/libpam/Makefile.am
+++ b/libpam/Makefile.am
@@ -3,7 +3,7 @@
#
AM_CFLAGS = -DDEFAULT_MODULE_PATH=\"$(SECUREDIR)/\" -DLIBPAM_COMPILE \
- -DLOCALEDIR=\"$(localedir)\" \
+ -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/libpam_internal/include \
-I$(srcdir)/include $(LIBPRELUDE_CFLAGS) $(ECONF_CFLAGS) \
-DPAM_VERSION=\"$(VERSION)\" -DSYSCONFDIR=\"$(sysconfdir)\" \
$(WARN_CFLAGS)
@@ -18,7 +18,7 @@ include_HEADERS = include/security/_pam_compat.h \
include/security/pam_ext.h include/security/pam_modutil.h
noinst_HEADERS = pam_prelude.h pam_private.h pam_tokens.h \
- pam_modutil_private.h include/pam_assemble_line.h \
+ pam_modutil_private.h \
include/pam_cc_compat.h include/pam_inline.h \
include/test_assert.h