aboutsummaryrefslogtreecommitdiff
path: root/modules/pam_access/Makefile.am
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2016-03-23 11:16:55 +0100
committerThorsten Kukuk <kukuk@thkukuk.de>2016-03-23 11:16:55 +0100
commita64de52d1621ac3d3dd03f66742b48bef0101043 (patch)
tree4425adf9b3f5c8fc49a7e86404c8fe65ac368cc9 /modules/pam_access/Makefile.am
parent11db6fd23dee9cf400a260b371edbd6091a96171 (diff)
downloadpam-a64de52d1621ac3d3dd03f66742b48bef0101043.tar.gz
pam-a64de52d1621ac3d3dd03f66742b48bef0101043.tar.bz2
pam-a64de52d1621ac3d3dd03f66742b48bef0101043.zip
Remove YP dependencies from pam_access, they were never used
and such not needed. * modules/pam_access/Makefile.am: Remove NIS_CFLAGS and NIS_LIBS * modules/pam_access/pam_access.c: Remove yp_get_default_domain case, it will never be used.
Diffstat (limited to 'modules/pam_access/Makefile.am')
-rw-r--r--modules/pam_access/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/pam_access/Makefile.am b/modules/pam_access/Makefile.am
index 05276747..6c0f738e 100644
--- a/modules/pam_access/Makefile.am
+++ b/modules/pam_access/Makefile.am
@@ -15,14 +15,14 @@ securelibdir = $(SECUREDIR)
secureconfdir = $(SCONFIGDIR)
AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
- -DPAM_ACCESS_CONFIG=\"$(SCONFIGDIR)/access.conf\" $(NIS_CFLAGS)
+ -DPAM_ACCESS_CONFIG=\"$(SCONFIGDIR)/access.conf\"
AM_LDFLAGS = -no-undefined -avoid-version -module
if HAVE_VERSIONING
AM_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
securelib_LTLIBRARIES = pam_access.la
-pam_access_la_LIBADD = $(top_builddir)/libpam/libpam.la $(NIS_LIBS)
+pam_access_la_LIBADD = $(top_builddir)/libpam/libpam.la
secureconf_DATA = access.conf