aboutsummaryrefslogtreecommitdiff
path: root/modules/pam_access
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2003-07-13 18:41:04 +0000
committerSteve Langasek <vorlon@debian.org>2003-07-13 18:41:04 +0000
commit2f36c829822a4b016ba075575c720ad9cb3c6463 (patch)
tree51b4a20becbd7b9d92b6bc0d73565a438525265d /modules/pam_access
parenteaffa5288f918a542c5322b79975793efc1b3a10 (diff)
downloadpam-2f36c829822a4b016ba075575c720ad9cb3c6463.tar.gz
pam-2f36c829822a4b016ba075575c720ad9cb3c6463.tar.bz2
pam-2f36c829822a4b016ba075575c720ad9cb3c6463.zip
Relevant BUGIDs: 643357
Purpose of commit: bugfix Commit summary: --------------- Patch from Sam Hartman to fix handling of module linking on Linux: modules should be linked against libpam if they call any functions from the library, since not all platforms will correctly resolve symbol references otherwise. Also, make sure we use gcc, not ld, when linking, since there's additional linker glue that gcc will pull in for us.
Diffstat (limited to 'modules/pam_access')
-rw-r--r--modules/pam_access/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/modules/pam_access/Makefile b/modules/pam_access/Makefile
index d93c9f40..87b2b3e6 100644
--- a/modules/pam_access/Makefile
+++ b/modules/pam_access/Makefile
@@ -10,6 +10,9 @@ include ../../Make.Rules
TITLE=pam_access
LOCAL_CONFILE=./access.conf
INSTALLED_CONFILE=$(SCONFIGD)/access.conf
+ifeq ($(HAVE_LIBNSL),yes)
+MODULE_SIMPLE_EXTRALIBS=-lnsl
+endif
DEFS=-DDEFAULT_CONF_FILE=\"$(INSTALLED_CONFILE)\"
CFLAGS += $(DEFS)