aboutsummaryrefslogtreecommitdiff
path: root/modules/pam_env/pam_env.c
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2022-01-23 08:00:00 +0000
committerDmitry V. Levin <ldv@altlinux.org>2022-01-23 08:00:00 +0000
commit5b94cc43524ac11b1c2b0370bdaba534358f8fa8 (patch)
tree2e4844ae7d37bef0d3b26ee6fd6b562be654230e /modules/pam_env/pam_env.c
parentf9ef347178123befd0bdfc2c101e7b78b04dea03 (diff)
downloadpam-5b94cc43524ac11b1c2b0370bdaba534358f8fa8.tar.gz
pam-5b94cc43524ac11b1c2b0370bdaba534358f8fa8.tar.bz2
pam-5b94cc43524ac11b1c2b0370bdaba534358f8fa8.zip
modules: move SCONFIGDIR-based macro definitions from Makefile.am to the source code
Since SCONFIGDIR macro is available, the is no need to define macros based on SCONFIGDIR in Makefile.am files. * modules/pam_access/Makefile.am (AM_CFLAGS): Move definitions of PAM_ACCESS_CONFIG and ACCESS_CONF_GLOB macros ... * modules/pam_access/pam_access.c: ... here. * modules/pam_env/Makefile.am (AM_CFLAGS): Move definition of DEFAULT_CONF_FILE macro ... * modules/pam_env/pam_env.c: ... here. * modules/pam_group/Makefile.am (AM_CFLAGS): Move definition of PAM_GROUP_CONF macro ... * modules/pam_group/pam_group.c: ... here. * modules/pam_limits/Makefile.am (AM_CFLAGS): Move definition of LIMITS_FILE macro ... * modules/pam_limits/pam_limits.c: ... here. * modules/pam_sepermit/Makefile.am (AM_CFLAGS): Move definition of SEPERMIT_CONF_FILE macro ... * modules/pam_sepermit/pam_sepermit.c: ... here. * modules/pam_time/Makefile.am (AM_CFLAGS): Move definition of PAM_TIME_CONF macro ... * modules/pam_time/pam_time.c: ... here.
Diffstat (limited to 'modules/pam_env/pam_env.c')
-rw-r--r--modules/pam_env/pam_env.c2
1 files changed, 2 insertions, 0 deletions
diff --git a/modules/pam_env/pam_env.c b/modules/pam_env/pam_env.c
index f5f8cead..c03ec3a3 100644
--- a/modules/pam_env/pam_env.c
+++ b/modules/pam_env/pam_env.c
@@ -41,6 +41,8 @@ typedef struct var {
char *override;
} VAR;
+#define DEFAULT_CONF_FILE (SCONFIGDIR "/pam_env.conf")
+
#define BUF_SIZE 8192
#define MAX_ENV 8192