aboutsummaryrefslogtreecommitdiff
path: root/modules/pam_pwhistory/opasswd.c
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@strace.io>2023-12-12 08:00:00 +0000
committerDmitry V. Levin <ldv@strace.io>2023-12-12 20:05:08 +0000
commitcf492d0cedf10d4128c5cf211998dff2260acb6a (patch)
tree8ba1eb14c454e6e24cf48e8dd5da22a0c3ce485c /modules/pam_pwhistory/opasswd.c
parentf6a171e5c7bcb7c0bf56ea0dc81e3b6843670fc4 (diff)
downloadpam-cf492d0cedf10d4128c5cf211998dff2260acb6a.tar.gz
pam-cf492d0cedf10d4128c5cf211998dff2260acb6a.tar.bz2
pam-cf492d0cedf10d4128c5cf211998dff2260acb6a.zip
treewide: assume getline exists
Apparently, getline is being used unconditionally in pam_namespace and pam_sepermit. In pam_namespace, it is being used since 2006 when the module was introduced in the first place. Let's assume getline is universally available and let's use it unconditionally in other cases, too. * configure.ac (AC_CHECK_FUNCS): Remove getline and getdelim. * libpam/pam_modutil_searchkey.c (pam_modutil_search_key): Use getline unconditionally. * modules/pam_pwhistory/opasswd.c (check_old_pass, save_old_pass): Likewise. * modules/pam_shells/pam_shells.c (perform_check): Likewise.
Diffstat (limited to 'modules/pam_pwhistory/opasswd.c')
-rw-r--r--modules/pam_pwhistory/opasswd.c38
1 files changed, 0 insertions, 38 deletions
diff --git a/modules/pam_pwhistory/opasswd.c b/modules/pam_pwhistory/opasswd.c
index 6e44ed2a..5f577dfd 100644
--- a/modules/pam_pwhistory/opasswd.c
+++ b/modules/pam_pwhistory/opasswd.c
@@ -173,24 +173,8 @@ check_old_pass, const char *user, const char *newpass, const char *filename, int
while (!feof (oldpf))
{
char *cp, *tmp;
-#if defined(HAVE_GETLINE)
ssize_t n = getline (&buf, &buflen, oldpf);
-#elif defined (HAVE_GETDELIM)
- ssize_t n = getdelim (&buf, &buflen, '\n', oldpf);
-#else
- ssize_t n;
- if (buf == NULL)
- {
- buflen = DEFAULT_BUFLEN;
- buf = malloc (buflen);
- if (buf == NULL)
- return PAM_BUF_ERR;
- }
- buf[0] = '\0';
- fgets (buf, buflen - 1, oldpf);
- n = strlen (buf);
-#endif /* HAVE_GETLINE / HAVE_GETDELIM */
cp = buf;
if (n < 1)
@@ -380,29 +364,7 @@ save_old_pass, const char *user, int howmany, const char *filename, int debug UN
while (!feof (oldpf))
{
char *cp, *tmp, *save;
-#if defined(HAVE_GETLINE)
ssize_t n = getline (&buf, &buflen, oldpf);
-#elif defined (HAVE_GETDELIM)
- ssize_t n = getdelim (&buf, &buflen, '\n', oldpf);
-#else
- ssize_t n;
-
- if (buf == NULL)
- {
- buflen = DEFAULT_BUFLEN;
- buf = malloc (buflen);
- if (buf == NULL)
- {
- fclose (oldpf);
- fclose (newpf);
- retval = PAM_BUF_ERR;
- goto error_opasswd;
- }
- }
- buf[0] = '\0';
- fgets (buf, buflen - 1, oldpf);
- n = strlen (buf);
-#endif /* HAVE_GETLINE / HAVE_GETDELIM */
if (n < 1)
break;