aboutsummaryrefslogtreecommitdiff
path: root/modules/pam_selinux
diff options
context:
space:
mode:
authorTobias Stoeckmann <tobias@stoeckmann.org>2024-01-21 23:05:36 +0100
committerDmitry V. Levin <ldv@strace.io>2024-01-21 22:36:10 +0000
commit70773c1a25dd5a2ae6611fddd7c4b1250ee429eb (patch)
tree2a3951a0a20ca095c7f177d94ed11b91b66e994e /modules/pam_selinux
parent2f89e9caa043fb96a66056e6f5387bcef7c030a3 (diff)
downloadpam-70773c1a25dd5a2ae6611fddd7c4b1250ee429eb.tar.gz
pam-70773c1a25dd5a2ae6611fddd7c4b1250ee429eb.tar.bz2
pam-70773c1a25dd5a2ae6611fddd7c4b1250ee429eb.zip
modules: add pamc headers to the search path only when needed
The pam client library libpamc is only needed if libpam_misc is in use. But libpam_misc is only used by an SELinux helper binary. Remove the libpamc includes from the search path in all other cases. Signed-off-by: Tobias Stoeckmann <tobias@stoeckmann.org>
Diffstat (limited to 'modules/pam_selinux')
-rw-r--r--modules/pam_selinux/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/modules/pam_selinux/Makefile.am b/modules/pam_selinux/Makefile.am
index d9b8e8c4..65d21edc 100644
--- a/modules/pam_selinux/Makefile.am
+++ b/modules/pam_selinux/Makefile.am
@@ -21,8 +21,7 @@ else
secureconfdir = $(SCONFIGDIR)
endif
-AM_CFLAGS = -I$(top_srcdir)/libpam/include -I$(top_srcdir)/libpamc/include \
- -I$(top_srcdir)/libpam_misc/include $(WARN_CFLAGS)
+AM_CFLAGS = -I$(top_srcdir)/libpam/include $(WARN_CFLAGS)
pam_selinux_la_LDFLAGS = -no-undefined -avoid-version -module
pam_selinux_la_LIBADD = $(top_builddir)/libpam/libpam.la @LIBSELINUX@ @LIBAUDIT@
@@ -32,6 +31,8 @@ endif
securelib_LTLIBRARIES = pam_selinux.la
noinst_PROGRAMS = pam_selinux_check
+pam_selinux_check_CFLAGS = $(AM_CFLAGS) -I$(top_srcdir)/libpamc/include \
+ -I$(top_srcdir)/libpam_misc/include
pam_selinux_check_LDADD = $(top_builddir)/libpam/libpam.la \
$(top_builddir)/libpam_misc/libpam_misc.la