aboutsummaryrefslogtreecommitdiff
path: root/modules/pam_unix/bigcrypt.c
diff options
context:
space:
mode:
authorThorsten Kukuk <kukuk@thkukuk.de>2006-06-15 21:09:49 +0000
committerThorsten Kukuk <kukuk@thkukuk.de>2006-06-15 21:09:49 +0000
commit3387d7584dc78587bb621b0bc4d4e80df576399e (patch)
treee9062f1e9d61115d15a8b5fc97d35567023760c2 /modules/pam_unix/bigcrypt.c
parent3ab490d6a2dd0b0466c334595f7c3460988e5ffd (diff)
downloadpam-3387d7584dc78587bb621b0bc4d4e80df576399e.tar.gz
pam-3387d7584dc78587bb621b0bc4d4e80df576399e.tar.bz2
pam-3387d7584dc78587bb621b0bc4d4e80df576399e.zip
Relevant BUGIDs:
Purpose of commit: cleanup Commit summary: --------------- Put bigcrypt prototype in own header instead of an external declaration in every single file calling bigcrypt: 2006-06-15 Thorsten Kukuk <kukuk@thkukuk.de> * modules/pam_unix/bigcrypt.h: New. * modules/pam_unix/Makefile.am: Add bigcrypt.h. * modules/pam_unix/bigcrypt.c: Include bigcrypt.h. * modules/pam_unix/support.c: Include bigcrypt.h, remove own prototype. * modules/pam_unix/bigcrypt_main.c: Include bigcrypt.h, remove own prototype. * modules/pam_unix/pam_unix_passwd.c: Include bigcrypt.h, remove own prototype.
Diffstat (limited to 'modules/pam_unix/bigcrypt.c')
-rw-r--r--modules/pam_unix/bigcrypt.c8
1 files changed, 6 insertions, 2 deletions
diff --git a/modules/pam_unix/bigcrypt.c b/modules/pam_unix/bigcrypt.c
index 6b73f3d2..d825bc71 100644
--- a/modules/pam_unix/bigcrypt.c
+++ b/modules/pam_unix/bigcrypt.c
@@ -24,12 +24,16 @@
* Andy Phillips <atp@mssl.ucl.ac.uk>
*/
+#include "config.h"
+
#include <string.h>
#include <stdlib.h>
#include <security/_pam_macros.h>
+#ifdef HAVE_CRYPT_H
+#include <crypt.h>
+#endif
-char *crypt(const char *key, const char *salt);
-char *bigcrypt(const char *key, const char *salt);
+#include "bigcrypt.h"
/*
* Max cleartext password length in segments of 8 characters this