aboutsummaryrefslogtreecommitdiff
path: root/modules
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2015-06-17 18:19:23 +0800
committerTomáš Mráz <t8m@users.noreply.github.com>2019-01-04 12:21:34 +0100
commit1d1d3b59af50c40efcc74f9c3f37b446a921e83e (patch)
treeccbfd1a2cbc3710b11a93942c136e28c748bfd2b /modules
parentd57ab22133654033ee1da89f128a81572d320985 (diff)
downloadpam-1d1d3b59af50c40efcc74f9c3f37b446a921e83e.tar.gz
pam-1d1d3b59af50c40efcc74f9c3f37b446a921e83e.tar.bz2
pam-1d1d3b59af50c40efcc74f9c3f37b446a921e83e.zip
build: ignore pam_rhosts if neither ruserok nor ruserok_af is available.
* configure.ac: check for ruserok and ruserok_af * modules/Makefile.am: ignore pam_rhosts/ if it's disabled * modules/pam_rhosts/pam_rhosts.c: include stdlib.h for malloc and free Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'modules')
-rw-r--r--modules/Makefile.am11
-rw-r--r--modules/pam_rhosts/pam_rhosts.c1
2 files changed, 9 insertions, 3 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index 0c80cea9..9ad26a9b 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -2,16 +2,21 @@
# Copyright (c) 2005, 2006, 2008 Thorsten Kukuk <kukuk@thkukuk.de>
#
-SUBDIRS = pam_access pam_cracklib pam_debug pam_deny pam_echo \
+if COND_BUILD_PAM_RHOSTS
+ MAYBE_PAM_RHOSTS = pam_rhosts
+endif
+
+SUBDIRS := pam_access pam_cracklib pam_debug pam_deny pam_echo \
pam_env pam_exec pam_faildelay pam_filter pam_ftp \
pam_group pam_issue pam_keyinit pam_lastlog pam_limits \
pam_listfile pam_localuser pam_loginuid pam_mail \
pam_mkhomedir pam_motd pam_namespace pam_nologin \
- pam_permit pam_pwhistory pam_rhosts pam_rootok pam_securetty \
+ pam_permit pam_pwhistory pam_rootok pam_securetty \
pam_selinux pam_sepermit pam_shells pam_stress \
pam_succeed_if pam_tally pam_tally2 pam_time pam_timestamp \
pam_tty_audit pam_umask \
- pam_unix pam_userdb pam_warn pam_wheel pam_xauth
+ pam_unix pam_userdb pam_warn pam_wheel pam_xauth \
+ $(MAYBE_PAM_RHOSTS)
CLEANFILES = *~
diff --git a/modules/pam_rhosts/pam_rhosts.c b/modules/pam_rhosts/pam_rhosts.c
index ed98d630..60c9e854 100644
--- a/modules/pam_rhosts/pam_rhosts.c
+++ b/modules/pam_rhosts/pam_rhosts.c
@@ -35,6 +35,7 @@
#include <pwd.h>
#include <netdb.h>
#include <string.h>
+#include <stdlib.h>
#include <syslog.h>
#define PAM_SM_AUTH /* only defines this management group */