aboutsummaryrefslogtreecommitdiff
path: root/modules
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@altlinux.org>2020-04-26 19:40:57 +0000
committerDmitry V. Levin <ldv@altlinux.org>2020-04-26 19:40:57 +0000
commit8731c4f6fd926b50a1c07bbbcf34e26cd60c5367 (patch)
treea8697578c852b5a58bc238ca8ac55b92f3c96155 /modules
parent33360292d4dfa8d53eb1e359cd5a2f516c9cc021 (diff)
downloadpam-8731c4f6fd926b50a1c07bbbcf34e26cd60c5367.tar.gz
pam-8731c4f6fd926b50a1c07bbbcf34e26cd60c5367.tar.bz2
pam-8731c4f6fd926b50a1c07bbbcf34e26cd60c5367.zip
build: move pam_selinux and pam_sepermit build conditions to modules/Makefile.am
* configure.ac (AM_CONDITIONAL): Replace HAVE_LIBSELINUX with COND_BUILD_PAM_SELINUX and COND_BUILD_PAM_SEPERMIT. * modules/Makefile.am [COND_BUILD_PAM_SELINUX] (MAYBE_PAM_SELINUX): Define. [COND_BUILD_PAM_SEPERMIT] (MAYBE_PAM_SEPERMIT): Likewise. (SUBDIRS): Replace pam_selinux with $(MAYBE_PAM_SELINUX), pam_sepermit with MAYBE_PAM_SEPERMIT. * modules/pam_selinux/Makefile.am: Assume HAVE_LIBSELINUX. * modules/pam_sepermit/Makefile.am: Likewise.
Diffstat (limited to 'modules')
-rw-r--r--modules/Makefile.am12
-rw-r--r--modules/pam_selinux/Makefile.am17
-rw-r--r--modules/pam_sepermit/Makefile.am13
3 files changed, 22 insertions, 20 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index 233c69db..13ef7c05 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -22,6 +22,14 @@ if COND_BUILD_PAM_RHOSTS
MAYBE_PAM_RHOSTS = pam_rhosts
endif
+if COND_BUILD_PAM_SELINUX
+ MAYBE_PAM_SELINUX = pam_selinux
+endif
+
+if COND_BUILD_PAM_SEPERMIT
+ MAYBE_PAM_SEPERMIT = pam_sepermit
+endif
+
if COND_BUILD_PAM_SETQUOTA
MAYBE_PAM_SETQUOTA = pam_setquota
endif
@@ -63,8 +71,8 @@ SUBDIRS := \
$(MAYBE_PAM_RHOSTS) \
pam_rootok \
pam_securetty \
- pam_selinux \
- pam_sepermit \
+ $(MAYBE_PAM_SELINUX) \
+ $(MAYBE_PAM_SEPERMIT) \
$(MAYBE_PAM_SETQUOTA) \
pam_shells \
pam_stress \
diff --git a/modules/pam_selinux/Makefile.am b/modules/pam_selinux/Makefile.am
index d037f483..c46d408e 100644
--- a/modules/pam_selinux/Makefile.am
+++ b/modules/pam_selinux/Makefile.am
@@ -8,11 +8,9 @@ MAINTAINERCLEANFILES = $(MANS) README
EXTRA_DIST = README $(XMLS) pam_selinux.8 pam_selinux_check.8 \
tst-pam_selinux
-if HAVE_LIBSELINUX
- TESTS = tst-pam_selinux
+TESTS = tst-pam_selinux
if HAVE_DOC
- man_MANS = pam_selinux.8
-endif
+man_MANS = pam_selinux.8
endif
XMLS = README.xml pam_selinux.8.xml
@@ -29,12 +27,11 @@ if HAVE_VERSIONING
pam_selinux_la_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
-if HAVE_LIBSELINUX
- securelib_LTLIBRARIES = pam_selinux.la
- noinst_PROGRAMS = pam_selinux_check
- pam_selinux_check_LDADD = $(top_builddir)/libpam/libpam.la \
- $(top_builddir)/libpam_misc/libpam_misc.la
-endif
+securelib_LTLIBRARIES = pam_selinux.la
+noinst_PROGRAMS = pam_selinux_check
+pam_selinux_check_LDADD = $(top_builddir)/libpam/libpam.la \
+ $(top_builddir)/libpam_misc/libpam_misc.la
+
if ENABLE_REGENERATE_MAN
noinst_DATA = README pam_selinux.8
README: pam_selinux.8.xml
diff --git a/modules/pam_sepermit/Makefile.am b/modules/pam_sepermit/Makefile.am
index 3895e124..1f68cf87 100644
--- a/modules/pam_sepermit/Makefile.am
+++ b/modules/pam_sepermit/Makefile.am
@@ -8,11 +8,9 @@ MAINTAINERCLEANFILES = $(MANS) README
EXTRA_DIST = README $(XMLS) pam_sepermit.8 sepermit.conf sepermit.conf.5 tst-pam_sepermit
-if HAVE_LIBSELINUX
- TESTS = tst-pam_sepermit
+TESTS = tst-pam_sepermit
if HAVE_DOC
- man_MANS = pam_sepermit.8 sepermit.conf.5
-endif
+man_MANS = pam_sepermit.8 sepermit.conf.5
endif
XMLS = README.xml pam_sepermit.8.xml sepermit.conf.5.xml
@@ -32,13 +30,12 @@ if HAVE_VERSIONING
pam_sepermit_la_LDFLAGS += -Wl,--version-script=$(srcdir)/../modules.map
endif
-if HAVE_LIBSELINUX
- secureconf_DATA = sepermit.conf
- securelib_LTLIBRARIES = pam_sepermit.la
+secureconf_DATA = sepermit.conf
+securelib_LTLIBRARIES = pam_sepermit.la
install-data-local:
mkdir -p $(DESTDIR)$(sepermitlockdir)
-endif
+
if ENABLE_REGENERATE_MAN
noinst_DATA = README pam_sepermit.8 sepermit.conf.5
README: pam_sepermit.8.xml