aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rw-r--r--debian/patches-applied/lib_security_multiarch_compat8
2 files changed, 8 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index d0fd74ef..592cda00 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,10 @@ pam (1.4.0-8) unstable; urgency=high
[ Sam Hartman ]
* Reword changelog
+ * Prefer the multiarch path (_PAM_ISA) to the non-multiarch path.
+ That's different than buster, but guarantees everything already
+ working in bullseye will continue to work and also guarantees that
+ when multiarch modules are available we use them.
-- Hideki Yamane <henrich@debian.org> Tue, 06 Jul 2021 22:09:15 +0900
diff --git a/debian/patches-applied/lib_security_multiarch_compat b/debian/patches-applied/lib_security_multiarch_compat
index e386ff39..2ac671a4 100644
--- a/debian/patches-applied/lib_security_multiarch_compat
+++ b/debian/patches-applied/lib_security_multiarch_compat
@@ -24,16 +24,16 @@ Index: pam-1.4.0/libpam/pam_handlers.c
+ mod->dl_handle = _pam_dlopen(mod_path);
+ } else {
+ char *mod_full_path = NULL;
-+ if (asprintf(&mod_full_path, "%s%s",
-+ DEFAULT_MODULE_PATH, mod_path) >= 0) {
++ if (asprintf(&mod_full_path, "%s/%s",
++ _PAM_ISA, mod_path) >= 0) {
+ mod->dl_handle = _pam_dlopen(mod_full_path);
+ _pam_drop(mod_full_path);
+ } else {
+ pam_syslog(pamh, LOG_CRIT, "cannot malloc full mod path");
+ }
+ if (!mod->dl_handle) {
-+ if (asprintf(&mod_full_path, "%s/%s",
-+ _PAM_ISA, mod_path) >= 0) {
++ if (asprintf(&mod_full_path, "%s%s",
++ DEFAULT_MODULE_PATH, mod_path) >= 0) {
+ mod->dl_handle = _pam_dlopen(mod_full_path);
+ _pam_drop(mod_full_path);
+ } else {