aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--changelog5
-rw-r--r--patches-applied/024_debian_cracklib_dict_path30
-rwxr-xr-xrules2
3 files changed, 20 insertions, 17 deletions
diff --git a/changelog b/changelog
index ce66f5cb..82e682a7 100644
--- a/changelog
+++ b/changelog
@@ -6,8 +6,11 @@ pam (0.99.7.1-3) UNRELEASED; urgency=low
* New patch misc_conv_allow_sigint.patch: allow SIGINT to be handled by the
application, instead of blocking it when misc_conv is in use and
preventing users from being able to ^C at any PAM prompt. Closes: #1708.
+ * 024_debian_cracklib_dict_path: default to NULL instead of a specific
+ dictionary path when none is defined for consistency with the new upstream
+ version of cracklib, and define our path in debian/rules.
- -- Steve Langasek <vorlon@debian.org> Mon, 27 Aug 2007 00:00:01 -0700
+ -- Steve Langasek <vorlon@debian.org> Mon, 27 Aug 2007 01:00:06 -0700
pam (0.99.7.1-2) unstable; urgency=low
diff --git a/patches-applied/024_debian_cracklib_dict_path b/patches-applied/024_debian_cracklib_dict_path
index 12434230..4a8833f7 100644
--- a/patches-applied/024_debian_cracklib_dict_path
+++ b/patches-applied/024_debian_cracklib_dict_path
@@ -1,30 +1,30 @@
Fix the cracklib autoconf check so that HAVE_CRACK_H gets defined.
Don't copy around the cracklib dictpath into a fixed-width buffer, when
-we can just point at the existing strings; and use the cracklib-provided
-default if no dictionary is specified in pam.conf.
+we can just point at the existing strings; and allow the means to
+specify a default dictionary when no dictionary is specified in
+pam.conf.
Authors: Steve Langasek <vorlon@debian.org>
-Upstream status: not yet submitted
+Upstream status: submitted in <20070826012650.GA18910@dario.dodds.net>
Index: Linux-PAM/modules/pam_cracklib/pam_cracklib.c
===================================================================
--- Linux-PAM/modules/pam_cracklib/pam_cracklib.c.orig
+++ Linux-PAM/modules/pam_cracklib/pam_cracklib.c
-@@ -54,6 +54,11 @@
- #include <crack.h>
- #else
+@@ -56,6 +56,10 @@
extern char *FascistCheck(char *pw, const char *dictpath);
-+static const char CRACKLIB_DICTPATH[] = "/usr/share/dict/cracklib_dict"
-+#endif
-+
-+#ifndef CRACKLIB_DICT
-+#define CRACKLIB_DICT CRACKLIB_DICTPATH
#endif
++#ifndef CRACKLIB_DICT
++#define CRACKLIB_DICT NULL
++#endif
++
+ /* For Translators: "%s%s" could be replaced with "<service> " or "". */
+ #define PROMPT1 _("New %s%spassword: ")
/* For Translators: "%s%s" could be replaced with "<service> " or "". */
-@@ -94,7 +99,7 @@
+@@ -94,7 +98,7 @@
int oth_credit;
int use_authtok;
char prompt_type[BUFSIZ];
@@ -33,7 +33,7 @@ Index: Linux-PAM/modules/pam_cracklib/pam_cracklib.c
};
#define CO_RETRY_TIMES 1
-@@ -159,14 +164,15 @@
+@@ -159,14 +163,15 @@
} else if (!strncmp(*argv,"use_authtok",11)) {
opt->use_authtok = 1;
} else if (!strncmp(*argv,"dictpath=",9)) {
@@ -52,7 +52,7 @@ Index: Linux-PAM/modules/pam_cracklib/pam_cracklib.c
return ctrl;
}
-@@ -514,8 +520,7 @@
+@@ -514,8 +519,7 @@
options.use_authtok = CO_USE_AUTHTOK;
memset(options.prompt_type, 0, BUFSIZ);
strcpy(options.prompt_type,"UNIX");
@@ -62,7 +62,7 @@ Index: Linux-PAM/modules/pam_cracklib/pam_cracklib.c
ctrl = _pam_parse(pamh, &options, argc, argv);
-@@ -609,7 +614,7 @@
+@@ -609,7 +613,7 @@
const char *crack_msg;
D(("against cracklib"));
diff --git a/rules b/rules
index 45e7c5ec..c4f47073 100755
--- a/rules
+++ b/rules
@@ -5,7 +5,7 @@
# architecture-dependant package, as well as an architecture-independant
# package.
-CFLAGS := -g -D_GNU_SOURCE -D_REENTRANT -fPIC
+CFLAGS := -g -D_GNU_SOURCE -D_REENTRANT -fPIC -DCRACKLIB_DICT=CRACKLIB_DICTPATH
LDFLAGS := -Wl,-z,defs
ifeq (,$(findstring noopt, ${DEB_BUILD_OPTIONS}))