aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac2
-rw-r--r--doc/.gitignore1
-rw-r--r--doc/Makefile.am4
-rw-r--r--doc/custom-html.xsl.in18
4 files changed, 2 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 3c6aea60..b05a61dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -269,8 +269,6 @@ AC_ARG_ENABLE(txt_stylesheet,
${MKDIR_P} doc
AC_SUBST(TXT_STYLESHEET)
-# It has to be TXT_STYLESHEET otherwise a html tree will be generated while generating all README files.
-sed "s+HTML_STYLESHEET+$TXT_STYLESHEET+g" <$srcdir/doc/custom-html.xsl.in >doc/custom-html.xsl
AC_ARG_ENABLE(pdf_stylesheet,
AS_HELP_STRING([--enable-pdf-stylesheet=FILE],[pdf stylesheet path @<:@default=http://docbook.sourceforge.net/release/xsl-ns/current/fo/docbook.xsl@:>@]),
diff --git a/doc/.gitignore b/doc/.gitignore
index ab4604bf..589288a9 100644
--- a/doc/.gitignore
+++ b/doc/.gitignore
@@ -3,4 +3,3 @@ MODULES-SGML
/*/*.txt
/*/html/
custom-man.xsl
-custom-html.xsl
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 88287cf5..80fc24c3 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -5,11 +5,11 @@
SUBDIRS = man specs sag adg mwg
CLEANFILES = *~
-DISTCLEANFILES = custom-html.xsl custom-man.xsl
+DISTCLEANFILES = custom-man.xsl
dist_html_DATA = index.html
-EXTRA_DIST = custom-html.xsl.in custom-man.xsl.in
+EXTRA_DIST = custom-man.xsl.in
#######################################################
diff --git a/doc/custom-html.xsl.in b/doc/custom-html.xsl.in
deleted file mode 100644
index b2eaf150..00000000
--- a/doc/custom-html.xsl.in
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version='1.0'?> <!--*-nxml-*-->
-<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
- xmlns:ss="http://docbook.sf.net/xmlns/string.subst/1.0"
- xmlns:exsl="http://exslt.org/common" version="1.0">
-
- <xsl:import href="HTML_STYLESHEET"/>
- <xsl:param name="vendordir"/>
-
- <xsl:template match="filename">
- <xsl:variable name="replacements">
- <ss:substitution oldstring="%vendordir%" newstring="{$vendordir}" />
- </xsl:variable>
- <xsl:call-template name="apply-string-subst-map">
- <xsl:with-param name="content" select="."/>
- <xsl:with-param name="map.contents" select="exsl:node-set($replacements)/*" />
- </xsl:call-template>
- </xsl:template>
-</xsl:stylesheet>