aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b22ab5b7..2bbbdc47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -529,12 +529,12 @@ fi
AC_ARG_ENABLE([selinux],
AS_HELP_STRING([--disable-selinux],[do not use SELinux]),
WITH_SELINUX=$enableval, WITH_SELINUX=yes)
-AM_CONDITIONAL([WITH_SELINUX], [test "$WITH_SELINUX" = "yes"])
if test "$WITH_SELINUX" = "yes" ; then
AC_CHECK_LIB([selinux],[getfilecon], LIBSELINUX="-lselinux", LIBSELINUX="")
else
LIBSELINUX=""
fi
+AM_CONDITIONAL([WITH_SELINUX], [test -n "$LIBSELINUX"])
AC_SUBST(LIBSELINUX)
if test -n "$LIBSELINUX" ; then
AC_DEFINE([WITH_SELINUX], 1, [Defined if SE Linux support is compiled in])