aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 5 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 026098f2..9e2562b9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -13,24 +13,19 @@ DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
LC_COLLATE=C
export LC_COLLATE
-export QUILT_PATCH_DIR = debian/patches-applied
d = $(CURDIR)/debian
dl = $(d)/local
%:
- dh $@ --with quilt,autoreconf
-
-# Since this is a 3.0 (quilt) source package, it has a .pc directory pointing
-# to debian/patches after initial unpack. This misleads quilt and makes
-# dh_quilt_unpatch fail hard.
-execute_before_dh_quilt_unpatch:
- if test "`cat .pc/.quilt_patches 2>/dev/null`" = debian/patches; then rm -Rf .pc; fi
+ dh $@
# avoid libaudit-dev when bootstrapping
ifneq (,$(filter stage1,$(DEB_BUILD_PROFILES)))
CONFIGURE_OPTS += --disable-audit
-endif
+endif
+
+CONFIGURE_OPTS += --enable-logind
override_dh_auto_configure:
# Explicitly set libdir, sbindir to avoid upstream's override logic.
@@ -40,6 +35,7 @@ override_dh_auto_configure:
--enable-isadir=/usr/lib/security \
--with-systemdunitdir=/usr/lib/systemd/system \
--disable-nis \
+ --enable-usergroups \
$(CONFIGURE_OPTS)
# .install files don't have "except for" handling, so we need to exclude