aboutsummaryrefslogtreecommitdiff
path: root/modules/pam_unix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pam_unix')
-rw-r--r--modules/pam_unix/Makefile.am19
1 files changed, 16 insertions, 3 deletions
diff --git a/modules/pam_unix/Makefile.am b/modules/pam_unix/Makefile.am
index a1dfe44e..84e26d42 100644
--- a/modules/pam_unix/Makefile.am
+++ b/modules/pam_unix/Makefile.am
@@ -8,9 +8,17 @@ MAINTAINERCLEANFILES = $(MANS) README
EXTRA_DIST = md5.c md5_crypt.c lckpwdf.-c yppasswd_xdr.c $(XMLS) CHANGELOG
if HAVE_DOC
-dist_man_MANS = pam_unix.8 unix_chkpwd.8 unix_update.8
+dist_man_MANS = pam_unix.8 unix_chkpwd.8
+if WITH_SELINUX
+dist_man_MANS += unix_update.8
endif
-XMLS = README.xml pam_unix.8.xml unix_chkpwd.8.xml unix_update.8.xml
+endif
+
+XMLS = README.xml pam_unix.8.xml unix_chkpwd.8.xml
+if WITH_SELINUX
+XMLS += unix_update.8.xml
+endif
+
dist_check_SCRIPTS = tst-pam_unix
TESTS = $(dist_check_SCRIPTS)
@@ -37,7 +45,10 @@ securelib_LTLIBRARIES = pam_unix.la
noinst_HEADERS = md5.h support.h yppasswd.h bigcrypt.h passverify.h
-sbin_PROGRAMS = unix_chkpwd unix_update
+sbin_PROGRAMS = unix_chkpwd
+if WITH_SELINUX
+sbin_PROGRAMS += unix_update
+endif
noinst_PROGRAMS = bigcrypt
@@ -58,11 +69,13 @@ unix_chkpwd_CFLAGS = $(AM_CFLAGS) @EXE_CFLAGS@ -DHELPER_COMPILE=\"unix_chkpwd\"
unix_chkpwd_LDFLAGS = @EXE_LDFLAGS@
unix_chkpwd_LDADD = @LIBCRYPT@ @LIBSELINUX@ @LIBAUDIT@
+if WITH_SELINUX
unix_update_SOURCES = unix_update.c md5_good.c md5_broken.c bigcrypt.c \
passverify.c
unix_update_CFLAGS = $(AM_CFLAGS) @EXE_CFLAGS@ -DHELPER_COMPILE=\"unix_update\"
unix_update_LDFLAGS = @EXE_LDFLAGS@
unix_update_LDADD = @LIBCRYPT@ @LIBSELINUX@
+endif
if ENABLE_REGENERATE_MAN
dist_noinst_DATA = README