From dba6cd9abf46b7368c43e668513cf6734b3c41d1 Mon Sep 17 00:00:00 2001
From: Thorsten Kukuk <kukuk@thkukuk.de>
Date: Thu, 15 Jun 2006 19:14:12 +0000
Subject: Relevant BUGIDs:

Purpose of commit: bugfix

Commit summary:
---------------

The Intel C Compiler (icc) claims to be gcc compatible, but
trys to interprets unknown options without error with fatal results...

2006-06-15  Thorsten Kukuk  <kukuk@thkukuk.de>

        * configure.in: Add special exceptions for icc: different
        compiler warnings, no PIE support.
---
 configure.in | 21 +++++++++++++++++++--
 1 file changed, 19 insertions(+), 2 deletions(-)

(limited to 'configure.in')

diff --git a/configure.in b/configure.in
index 23faeab6..f265b835 100644
--- a/configure.in
+++ b/configure.in
@@ -71,7 +71,7 @@ AC_PROG_LIBTOOL
 # Largefile support
 AC_SYS_LARGEFILE
 
-if eval "test x$GCC = xyes"; then
+if eval "test x$GCC = xyes -a $CC != icc"; then
   for flag in \
       -W \
       -Wall \
@@ -90,6 +90,23 @@ if eval "test x$GCC = xyes"; then
     JAPHAR_GREP_CFLAGS($flag, [ CFLAGS="$CFLAGS $flag" ])
   done
 fi
+if eval "test x$CC = xicc"; then
+  for flag in \
+      -Wall \
+      -Wmissing-prototypes \
+      -Wpointer-arith \
+      -Wreturn-type \
+      -Wstrict-prototypes \
+      -Wwrite-strings \
+      -Wshadow \
+      -Wp64 \
+      -Wdeprecated \
+      -Wuninitialized \
+      -Wmain
+  do
+    JAPHAR_GREP_CFLAGS($flag, [ CFLAGS="$CFLAGS $flag" ])
+  done
+fi
 
 AC_C___ATTRIBUTE__
 
@@ -158,7 +175,7 @@ AC_CACHE_CHECK(for -fpie, libc_cv_fpie, [dnl
 int foo;
 main () { return 0;}
 EOF
-  if test "$USE_PIE" = "yes" &&
+  if test "$USE_PIE" = "yes" -a "$CC" != "icc" &&
         AC_TRY_COMMAND([${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS -pie -fpie
                               -o conftest conftest.c 1>&AS_MESSAGE_LOG_FD])
   then
-- 
cgit v1.2.3