aboutsummaryrefslogtreecommitdiff
path: root/store/works/life/cpp-practicum/CMakeLists.txt
diff options
context:
space:
mode:
authorYuqian Yang <crupest@crupest.life>2025-02-28 23:13:39 +0800
committerYuqian Yang <crupest@crupest.life>2025-02-28 23:13:39 +0800
commitdc1f0c4c0096013799416664894c5194dc7e1f52 (patch)
tree2f5d235f778cd720f4c39ec3e56b77ba6d99f375 /store/works/life/cpp-practicum/CMakeLists.txt
parent7299d424d90b1effb6db69e3476ddd5af72eeba4 (diff)
downloadcrupest-dc1f0c4c0096013799416664894c5194dc7e1f52.tar.gz
crupest-dc1f0c4c0096013799416664894c5194dc7e1f52.tar.bz2
crupest-dc1f0c4c0096013799416664894c5194dc7e1f52.zip
chore(store): move everything to store.
Diffstat (limited to 'store/works/life/cpp-practicum/CMakeLists.txt')
-rw-r--r--store/works/life/cpp-practicum/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/store/works/life/cpp-practicum/CMakeLists.txt b/store/works/life/cpp-practicum/CMakeLists.txt
new file mode 100644
index 0000000..346fdb4
--- /dev/null
+++ b/store/works/life/cpp-practicum/CMakeLists.txt
@@ -0,0 +1,33 @@
+cmake_minimum_required(VERSION 3.14)
+
+set(CMAKE_TOOLCHAIN_FILE $ENV{VCPKG_INSTALLATION_ROOT}/scripts/buildsystems/vcpkg.cmake
+ CACHE STRING "Vcpkg toolchain file")
+
+project(CppPraticum)
+
+enable_testing()
+
+set(CMAKE_CXX_STANDARD 17)
+
+if (MSVC)
+ string(REGEX REPLACE "/W[0-4]\\s*" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
+ add_compile_options(/utf-8 /W4 /WX)
+endif()
+
+find_package(Qt5Core CONFIG REQUIRED)
+find_package(Qt5Gui CONFIG REQUIRED)
+find_package(Qt5Widgets CONFIG REQUIRED)
+
+add_executable(main
+ Base.hpp
+
+ Book.hpp
+ Book.cpp
+ Vendor.hpp
+ Vendor.cpp
+ Record.hpp
+ Record.cpp
+
+ main.cpp
+)
+target_link_libraries(main PRIVATE Qt5::Core Qt5::Widgets Qt5::Gui)