aboutsummaryrefslogtreecommitdiff
path: root/tool/modules/setup.py
diff options
context:
space:
mode:
authorcrupest <crupest@outlook.com>2023-05-31 23:55:57 +0800
committercrupest <crupest@outlook.com>2023-05-31 23:55:57 +0800
commit4cc25bea963c09a1eb0f951bed1eabc75d196446 (patch)
tree2f5aa4fe9684a19463255b454162cc84d35ccc2a /tool/modules/setup.py
parent4e6260b7d03a38be65203139631d5fda523e80af (diff)
downloadcrupest-4cc25bea963c09a1eb0f951bed1eabc75d196446.tar.gz
crupest-4cc25bea963c09a1eb0f951bed1eabc75d196446.tar.bz2
crupest-4cc25bea963c09a1eb0f951bed1eabc75d196446.zip
Add v2ray.
Diffstat (limited to 'tool/modules/setup.py')
-rw-r--r--tool/modules/setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/tool/modules/setup.py b/tool/modules/setup.py
index 0e802c4..4e91302 100644
--- a/tool/modules/setup.py
+++ b/tool/modules/setup.py
@@ -143,7 +143,7 @@ def template_generate(console):
"Great! Check the config file and see you next time!", style="green")
to_gen = False
- domain = config["CRUPEST_DOMAIN"]
+ domain = get_domain()
if to_gen:
console.print(
@@ -186,7 +186,7 @@ def template_generate(console):
to_gen_nginx_conf = Confirm.ask("[yellow]It seems you have already generated nginx config. Do you want to overwrite it?[/]",
default=False, console=console)
if to_gen_nginx_conf:
- nginx(domain, console)
+ nginx(domain, config, console)
data_dir_check(domain, console)