aboutsummaryrefslogtreecommitdiff
path: root/works/life/algorithm-experiment/CMakeLists.txt
diff options
context:
space:
mode:
authorcrupest <crupest@outlook.com>2021-10-23 18:45:55 +0800
committercrupest <crupest@outlook.com>2021-10-23 18:45:55 +0800
commite6c2aff22fbf338a21e9fbb6dbf1492f607f297d (patch)
treea8c07c835261547ba1df7d21032087aff56a27de /works/life/algorithm-experiment/CMakeLists.txt
parent01cf50d0c0bce56a1c2599e6ab77033ce9595450 (diff)
downloadcrupest-e6c2aff22fbf338a21e9fbb6dbf1492f607f297d.tar.gz
crupest-e6c2aff22fbf338a21e9fbb6dbf1492f607f297d.tar.bz2
crupest-e6c2aff22fbf338a21e9fbb6dbf1492f607f297d.zip
import(life): Add algorithm experiment 3.
Diffstat (limited to 'works/life/algorithm-experiment/CMakeLists.txt')
-rw-r--r--works/life/algorithm-experiment/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/works/life/algorithm-experiment/CMakeLists.txt b/works/life/algorithm-experiment/CMakeLists.txt
new file mode 100644
index 0000000..8f7c4d5
--- /dev/null
+++ b/works/life/algorithm-experiment/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.21)
+
+set(CMAKE_TOOLCHAIN_FILE $ENV{VCPKG_INSTALLATION_ROOT}/scripts/buildsystems/vcpkg.cmake
+ CACHE STRING "Vcpkg toolchain file")
+
+set(CMAKE_CXX_STANDARD 20)
+
+project(cru-algorithm-experiment)
+
+find_package(dlib CONFIG REQUIRED)
+
+add_executable(3.1 3.1.cpp)
+target_link_libraries(3.1 PRIVATE dlib::dlib)
+
+add_executable(3.2 3.2.cpp)
+target_link_libraries(3.2 PRIVATE dlib::dlib)