aboutsummaryrefslogtreecommitdiff
path: root/works/life/cpp-practicum/CMakeLists.txt
diff options
context:
space:
mode:
authorYuqian Yang <crupest@crupest.life>2025-02-12 15:55:21 +0800
committerYuqian Yang <crupest@crupest.life>2025-02-12 15:55:21 +0800
commit10eb95869601e145b1d8bc909424777c25752d51 (patch)
tree49449a4076ded9bd937a51679318edbe2a532cae /works/life/cpp-practicum/CMakeLists.txt
parent29ba3e88b1a7425fe00af0005b8a8228103aa21c (diff)
parentf8c10dd1fc55e60f35286475356e48c4f642eb63 (diff)
downloadcrupest-10eb95869601e145b1d8bc909424777c25752d51.tar.gz
crupest-10eb95869601e145b1d8bc909424777c25752d51.tar.bz2
crupest-10eb95869601e145b1d8bc909424777c25752d51.zip
import(life): IMPORT crupest/life COMPLETE.
Diffstat (limited to 'works/life/cpp-practicum/CMakeLists.txt')
-rw-r--r--works/life/cpp-practicum/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/works/life/cpp-practicum/CMakeLists.txt b/works/life/cpp-practicum/CMakeLists.txt
new file mode 100644
index 0000000..346fdb4
--- /dev/null
+++ b/works/life/cpp-practicum/CMakeLists.txt
@@ -0,0 +1,33 @@
+cmake_minimum_required(VERSION 3.14)
+
+set(CMAKE_TOOLCHAIN_FILE $ENV{VCPKG_INSTALLATION_ROOT}/scripts/buildsystems/vcpkg.cmake
+ CACHE STRING "Vcpkg toolchain file")
+
+project(CppPraticum)
+
+enable_testing()
+
+set(CMAKE_CXX_STANDARD 17)
+
+if (MSVC)
+ string(REGEX REPLACE "/W[0-4]\\s*" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
+ add_compile_options(/utf-8 /W4 /WX)
+endif()
+
+find_package(Qt5Core CONFIG REQUIRED)
+find_package(Qt5Gui CONFIG REQUIRED)
+find_package(Qt5Widgets CONFIG REQUIRED)
+
+add_executable(main
+ Base.hpp
+
+ Book.hpp
+ Book.cpp
+ Vendor.hpp
+ Vendor.cpp
+ Record.hpp
+ Record.cpp
+
+ main.cpp
+)
+target_link_libraries(main PRIVATE Qt5::Core Qt5::Widgets Qt5::Gui)