aboutsummaryrefslogtreecommitdiff
path: root/works/life/cpp-practicum/CMakeLists.txt
diff options
context:
space:
mode:
authorcrupest <crupest@outlook.com>2020-12-29 22:52:02 +0800
committercrupest <crupest@outlook.com>2020-12-29 22:52:02 +0800
commit168c9a009eb68697c1b8328cfbf3a1a6ccae48f6 (patch)
tree8d1e3be48cc45d7fb0770c4196ac041561efd544 /works/life/cpp-practicum/CMakeLists.txt
parent9a7553406beef499f64d220131ac02465f524ee1 (diff)
downloadcrupest-168c9a009eb68697c1b8328cfbf3a1a6ccae48f6.tar.gz
crupest-168c9a009eb68697c1b8328cfbf3a1a6ccae48f6.tar.bz2
crupest-168c9a009eb68697c1b8328cfbf3a1a6ccae48f6.zip
import(life): ...
Diffstat (limited to 'works/life/cpp-practicum/CMakeLists.txt')
-rw-r--r--works/life/cpp-practicum/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/works/life/cpp-practicum/CMakeLists.txt b/works/life/cpp-practicum/CMakeLists.txt
new file mode 100644
index 0000000..fbf1c13
--- /dev/null
+++ b/works/life/cpp-practicum/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.14)
+
+project(CppPraticum)
+
+enable_testing()
+
+set(CMAKE_CXX_STANDARD 17)
+
+if (MSVC)
+ string(REGEX REPLACE "/W[0-4]\\s*" "" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS})
+ add_compile_options(/utf-8 /W4 /WX)
+endif()
+
+add_executable(main main.cpp Base.hpp StringUtil.hpp StringUtil.cpp)