aboutsummaryrefslogtreecommitdiff
path: root/works/life/cpp-practicum/CMakeLists.txt
diff options
context:
space:
mode:
authorcrupest <crupest@outlook.com>2020-12-30 15:37:39 +0800
committercrupest <crupest@outlook.com>2020-12-30 15:37:39 +0800
commite0964bbc4f66e7d193abd249213c9cf762fd0294 (patch)
treeee4f5307fc555ef66a3752e20388dca8f386c2f1 /works/life/cpp-practicum/CMakeLists.txt
parent7e9e803b33a9380d2ff3111c8d11f25f5d2b98ec (diff)
downloadcrupest-e0964bbc4f66e7d193abd249213c9cf762fd0294.tar.gz
crupest-e0964bbc4f66e7d193abd249213c9cf762fd0294.tar.bz2
crupest-e0964bbc4f66e7d193abd249213c9cf762fd0294.zip
import(life): ...
Diffstat (limited to 'works/life/cpp-practicum/CMakeLists.txt')
-rw-r--r--works/life/cpp-practicum/CMakeLists.txt21
1 files changed, 20 insertions, 1 deletions
diff --git a/works/life/cpp-practicum/CMakeLists.txt b/works/life/cpp-practicum/CMakeLists.txt
index fbf1c13..7958850 100644
--- a/works/life/cpp-practicum/CMakeLists.txt
+++ b/works/life/cpp-practicum/CMakeLists.txt
@@ -1,3 +1,6 @@
+set(CMAKE_TOOLCHAIN_FILE ${CMAKE_CURRENT_SOURCE_DIR}/../vcpkg/scripts/buildsystems/vcpkg.cmake
+ CACHE STRING "Vcpkg toolchain file")
+
cmake_minimum_required(VERSION 3.14)
project(CppPraticum)
@@ -11,4 +14,20 @@ if (MSVC)
add_compile_options(/utf-8 /W4 /WX)
endif()
-add_executable(main main.cpp Base.hpp StringUtil.hpp StringUtil.cpp)
+find_package(Qt5Core CONFIG REQUIRED)
+find_package(Qt5Gui CONFIG REQUIRED)
+find_package(Qt5Widgets CONFIG REQUIRED)
+
+add_executable(main
+ Base.hpp
+
+ Book.hpp
+ Book.cpp
+ Vendor.hpp
+ Vendor.cpp
+ Record.hpp
+ Record.cpp
+
+ main.cpp
+)
+target_link_libraries(main PRIVATE Qt5::Core Qt5::Widgets Qt5::Gui)