aboutsummaryrefslogtreecommitdiff
path: root/works/life/operating-system-experiment/CMakeLists.txt
diff options
context:
space:
mode:
authorcrupest <crupest@outlook.com>2021-06-09 22:28:01 +0800
committercrupest <crupest@outlook.com>2021-06-09 22:28:01 +0800
commit8bdb5db67fa3eeda755511f91fd257bde548a18f (patch)
tree2f8bdc79c6106c8cd4500113b8dd764316bf9896 /works/life/operating-system-experiment/CMakeLists.txt
parentd42dfdf4b903763997d47b6e2214c2ce33b9bf8e (diff)
downloadcrupest-8bdb5db67fa3eeda755511f91fd257bde548a18f.tar.gz
crupest-8bdb5db67fa3eeda755511f91fd257bde548a18f.tar.bz2
crupest-8bdb5db67fa3eeda755511f91fd257bde548a18f.zip
import(life): ...
Diffstat (limited to 'works/life/operating-system-experiment/CMakeLists.txt')
-rw-r--r--works/life/operating-system-experiment/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/works/life/operating-system-experiment/CMakeLists.txt b/works/life/operating-system-experiment/CMakeLists.txt
index 2c46b0f..540574b 100644
--- a/works/life/operating-system-experiment/CMakeLists.txt
+++ b/works/life/operating-system-experiment/CMakeLists.txt
@@ -12,6 +12,10 @@ find_package(Microsoft.GSL CONFIG REQUIRED)
add_library(cru_system SHARED Thread.cpp)
target_link_libraries(cru_system PUBLIC Microsoft.GSL::GSL fmt::fmt)
target_compile_definitions(cru_system PUBLIC CRU_EXPORT_API)
+if(UNIX)
+target_link_libraries(cru_system PUBLIC pthread)
+endif()
+
add_executable(main main.cpp)
target_link_libraries(main PRIVATE cru_system) \ No newline at end of file