aboutsummaryrefslogtreecommitdiff
path: root/store/works/teapot/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'store/works/teapot/CMakeLists.txt')
-rw-r--r--store/works/teapot/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/store/works/teapot/CMakeLists.txt b/store/works/teapot/CMakeLists.txt
new file mode 100644
index 0000000..0bbff29
--- /dev/null
+++ b/store/works/teapot/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+cmake_minimum_required(VERSION 3.16)
+project(crupest-teapot LANGUAGES CXX)
+
+set(CMAKE_AUTOMOC ON)
+
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Quick Quick3D)
+
+qt_add_executable(crupest-teapot
+ main.cpp
+)
+
+set_target_properties(crupest-teapot PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+
+target_link_libraries(crupest-teapot PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Quick
+ Qt::Quick3D
+)
+
+qt_add_qml_module(crupest-teapot
+ URI Example
+ VERSION 1.0
+ QML_FILES main.qml
+ RESOURCES teapot.mesh
+ NO_RESOURCE_TARGET_PATH
+)
+
+install(TARGETS crupest-teapot)