aboutsummaryrefslogtreecommitdiff
path: root/tools/cru-py/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tools/cru-py/pyproject.toml')
-rw-r--r--tools/cru-py/pyproject.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/tools/cru-py/pyproject.toml b/tools/cru-py/pyproject.toml
new file mode 100644
index 0000000..bbf7873
--- /dev/null
+++ b/tools/cru-py/pyproject.toml
@@ -0,0 +1,28 @@
+[tool.poetry]
+package-mode = false
+name = "cru"
+version = "0.1.0"
+description = ""
+authors = ["Yuqian Yang <crupest@crupest.life>"]
+license = "MIT"
+readme = "README.md"
+
+[tool.poetry.dependencies]
+python = "^3.11"
+rich = "^13.9.4"
+jsonschema = "^4.23.0"
+cryptography = "^43.0.3"
+
+[tool.poetry.group.dev.dependencies]
+black = "^24.10.0"
+isort = "^5.13.2"
+flake8 = "^7.1.1"
+flake8-bugbear = "^24.10.31"
+mypy = "^1.13.0"
+
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"
+
+[tool.isort]
+profile = "black"