aboutsummaryrefslogtreecommitdiff
path: root/works/life/computer-graphics-experiment/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'works/life/computer-graphics-experiment/CMakeLists.txt')
-rw-r--r--works/life/computer-graphics-experiment/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/works/life/computer-graphics-experiment/CMakeLists.txt b/works/life/computer-graphics-experiment/CMakeLists.txt
new file mode 100644
index 0000000..b9557d4
--- /dev/null
+++ b/works/life/computer-graphics-experiment/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.14)
+
+set(CMAKE_TOOLCHAIN_FILE $ENV{VCPKG_INSTALLATION_ROOT}/scripts/buildsystems/vcpkg.cmake
+ CACHE STRING "Vcpkg toolchain file")
+
+set(CMAKE_CXX_STANDARD 20)
+
+project(computer-graphics-experiment)
+
+find_package(glad CONFIG REQUIRED)
+find_package(glfw3 CONFIG REQUIRED)
+
+add_executable(4 4.cpp)
+target_link_libraries(4 PRIVATE glad::glad glfw)