aboutsummaryrefslogtreecommitdiff
path: root/works/life/information-security-experiment/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'works/life/information-security-experiment/CMakeLists.txt')
-rw-r--r--works/life/information-security-experiment/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/works/life/information-security-experiment/CMakeLists.txt b/works/life/information-security-experiment/CMakeLists.txt
new file mode 100644
index 0000000..f44e2f1
--- /dev/null
+++ b/works/life/information-security-experiment/CMakeLists.txt
@@ -0,0 +1,19 @@
+cmake_minimum_required(VERSION 3.20)
+
+set(CMAKE_TOOLCHAIN_FILE $ENV{VCPKG_INSTALLATION_ROOT}/scripts/buildsystems/vcpkg.cmake
+ CACHE STRING "Vcpkg toolchain file")
+
+project(information-security-experiment)
+
+set(CMAKE_CXX_STANDARD 20)
+
+find_package(OpenSSL REQUIRED)
+
+add_executable(des des.cpp)
+target_link_libraries(des PRIVATE OpenSSL::Crypto)
+
+add_executable(md5 md5.cpp)
+target_link_libraries(md5 PRIVATE OpenSSL::Crypto)
+
+add_executable(rsa rsa.cpp)
+target_link_libraries(rsa PRIVATE OpenSSL::Crypto)