aboutsummaryrefslogtreecommitdiff
path: root/works/life/information-security-experiment/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'works/life/information-security-experiment/CMakeLists.txt')
-rw-r--r--works/life/information-security-experiment/CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/works/life/information-security-experiment/CMakeLists.txt b/works/life/information-security-experiment/CMakeLists.txt
deleted file mode 100644
index f44e2f1..0000000
--- a/works/life/information-security-experiment/CMakeLists.txt
+++ /dev/null
@@ -1,19 +0,0 @@
-cmake_minimum_required(VERSION 3.20)
-
-set(CMAKE_TOOLCHAIN_FILE $ENV{VCPKG_INSTALLATION_ROOT}/scripts/buildsystems/vcpkg.cmake
- CACHE STRING "Vcpkg toolchain file")
-
-project(information-security-experiment)
-
-set(CMAKE_CXX_STANDARD 20)
-
-find_package(OpenSSL REQUIRED)
-
-add_executable(des des.cpp)
-target_link_libraries(des PRIVATE OpenSSL::Crypto)
-
-add_executable(md5 md5.cpp)
-target_link_libraries(md5 PRIVATE OpenSSL::Crypto)
-
-add_executable(rsa rsa.cpp)
-target_link_libraries(rsa PRIVATE OpenSSL::Crypto)