aboutsummaryrefslogtreecommitdiff
path: root/works/life/operating-system-experiment/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'works/life/operating-system-experiment/CMakeLists.txt')
-rw-r--r--works/life/operating-system-experiment/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/works/life/operating-system-experiment/CMakeLists.txt b/works/life/operating-system-experiment/CMakeLists.txt
index 139d2ba..bd50319 100644
--- a/works/life/operating-system-experiment/CMakeLists.txt
+++ b/works/life/operating-system-experiment/CMakeLists.txt
@@ -9,7 +9,7 @@ set(CMAKE_CXX_STANDARD 17)
find_package(fmt CONFIG REQUIRED)
find_package(Microsoft.GSL CONFIG REQUIRED)
-add_library(cru_system SHARED Thread.cpp Mutex.cpp)
+add_library(cru_system SHARED Thread.cpp Mutex.cpp Interlocked.cpp)
target_link_libraries(cru_system PUBLIC Microsoft.GSL::GSL fmt::fmt)
target_compile_definitions(cru_system PUBLIC CRU_EXPORT_API)
if(UNIX)