aboutsummaryrefslogtreecommitdiff
path: root/absl/base/CMakeLists.txt
diff options
context:
space:
mode:
authorEvan Brown <ezb@google.com>2024-07-10 12:44:39 -0700
committerCopybara-Service <copybara-worker@google.com>2024-07-10 12:45:28 -0700
commit5b6285e7c5548adf74396650c473efb163363705 (patch)
tree969d74ba9f19d4a4b563de511aea870d629c926a /absl/base/CMakeLists.txt
parentbb50cad0adb77f6afdab1d50c093aae2b36d0522 (diff)
downloadabseil-5b6285e7c5548adf74396650c473efb163363705.tar.gz
abseil-5b6285e7c5548adf74396650c473efb163363705.tar.bz2
abseil-5b6285e7c5548adf74396650c473efb163363705.zip
Roll forward poisoned pointer API and fix portability issues.
Also, return the middle of the poisoned block. PiperOrigin-RevId: 651119057 Change-Id: Iae0fc3dcb40e32cd449f469d9b8d62c37f3773f4
Diffstat (limited to 'absl/base/CMakeLists.txt')
-rw-r--r--absl/base/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/absl/base/CMakeLists.txt b/absl/base/CMakeLists.txt
index e010efec..97994fc6 100644
--- a/absl/base/CMakeLists.txt
+++ b/absl/base/CMakeLists.txt
@@ -739,3 +739,33 @@ absl_cc_test(
absl::optional
GTest::gtest_main
)
+
+absl_cc_library(
+ NAME
+ poison
+ SRCS
+ "internal/poison.cc"
+ HDRS
+ "internal/poison.h"
+ COPTS
+ ${ABSL_DEFAULT_COPTS}
+ LINKOPTS
+ ${ABSL_DEFAULT_LINKOPTS}
+ DEPS
+ absl::config
+ absl::core_headers
+ absl::malloc_internal
+)
+
+absl_cc_test(
+ NAME
+ poison_test
+ SRCS
+ "internal/poison_test.cc"
+ COPTS
+ ${ABSL_TEST_COPTS}
+ DEPS
+ absl::config
+ absl::poison
+ GTest::gtest_main
+)