aboutsummaryrefslogtreecommitdiff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorEvan Brown <ezb@google.com>2024-03-12 14:29:39 -0700
committerCopybara-Service <copybara-worker@google.com>2024-03-12 14:31:30 -0700
commit038561296676d1cae4a3cee30f8c924befbb6083 (patch)
tree724042c21eb6dfc0913a1eff86ffc7da3e0f4274 /absl/container/CMakeLists.txt
parent3c1f9be71ee280539f02e57c5e461b0271f54e91 (diff)
downloadabseil-038561296676d1cae4a3cee30f8c924befbb6083.tar.gz
abseil-038561296676d1cae4a3cee30f8c924befbb6083.tar.bz2
abseil-038561296676d1cae4a3cee30f8c924befbb6083.zip
Add extern templates for common swisstable types.
Motivation: mitigate linker input size increase from swisstable optimizations. Note: the changes in raw_hash_set.h are fixing build errors that happened when adding the explicit instantiations. The change in unchecked_deref is because set iterators have const reference access whereas map iterators have mutable reference access and the function is never actually called for sets (it's used in raw_hash_map) so it wasn't needed before. I'm not sure why the soo_slot/soo_iterator problems didn't cause compile errors earlier. PiperOrigin-RevId: 615174043 Change-Id: Iac5eb2332a76e9b70021156fbb2b8def47a5391d
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 4b08e6a3..8e64adb1 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -283,13 +283,17 @@ absl_cc_library(
flat_hash_map
HDRS
"flat_hash_map.h"
+ SRCS
+ "flat_hash_map.cc"
COPTS
${ABSL_DEFAULT_COPTS}
DEPS
+ absl::config
absl::container_memory
absl::core_headers
absl::hash_function_defaults
absl::raw_hash_map
+ absl::raw_hash_set
absl::algorithm_container
absl::memory
PUBLIC
@@ -321,9 +325,12 @@ absl_cc_library(
flat_hash_set
HDRS
"flat_hash_set.h"
+ SRCS
+ "flat_hash_set.cc"
COPTS
${ABSL_DEFAULT_COPTS}
DEPS
+ absl::config
absl::container_memory
absl::hash_function_defaults
absl::raw_hash_set
@@ -362,14 +369,18 @@ absl_cc_library(
node_hash_map
HDRS
"node_hash_map.h"
+ SRCS
+ "node_hash_map.cc"
COPTS
${ABSL_DEFAULT_COPTS}
DEPS
+ absl::config
absl::container_memory
absl::core_headers
absl::hash_function_defaults
absl::node_slot_policy
absl::raw_hash_map
+ absl::raw_hash_set
absl::algorithm_container
absl::memory
PUBLIC
@@ -398,9 +409,12 @@ absl_cc_library(
node_hash_set
HDRS
"node_hash_set.h"
+ SRCS
+ "node_hash_set.cc"
COPTS
${ABSL_DEFAULT_COPTS}
DEPS
+ absl::config
absl::container_memory
absl::core_headers
absl::hash_function_defaults