aboutsummaryrefslogtreecommitdiff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorDennis Kormalev <denk@google.com>2024-02-07 08:39:23 -0800
committerCopybara-Service <copybara-worker@google.com>2024-02-07 08:40:46 -0800
commit643b48a3b4362a932c0e41afce62deb55adf825b (patch)
tree5e5b68000ddde6fe775e2379b18e7dfa0ad98e11 /absl/container/CMakeLists.txt
parente22f9c1fdd00f2ad3cfdd1dd7a67145eadc3b21c (diff)
downloadabseil-643b48a3b4362a932c0e41afce62deb55adf825b.tar.gz
abseil-643b48a3b4362a932c0e41afce62deb55adf825b.tar.bz2
abseil-643b48a3b4362a932c0e41afce62deb55adf825b.zip
Add absl_container_hash-based HashEq specialization
SwissTable provides support for heterogeneous lookup in associative containers through transparent Hash and Eq types. However, it is not possible for user types to provide additional specializations to allow their types to use this functionality. This CL brings ability for user types to specify their own transparent absl_container_hash and (optionally) absl_container_eq inner types to achieve the same functionality. PiperOrigin-RevId: 604994859 Change-Id: I302486d292c9a18b7d4c77033227008f5539e354
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index 85af0bd7..4b08e6a3 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -471,9 +471,11 @@ absl_cc_library(
${ABSL_DEFAULT_COPTS}
DEPS
absl::config
+ absl::container_common
absl::cord
absl::hash
absl::strings
+ absl::type_traits
PUBLIC
)
@@ -487,6 +489,8 @@ absl_cc_test(
DEPS
absl::cord
absl::cord_test_helpers
+ absl::flat_hash_map
+ absl::flat_hash_set
absl::hash_function_defaults
absl::hash
absl::random_random