aboutsummaryrefslogtreecommitdiff
path: root/absl/container/CMakeLists.txt
diff options
context:
space:
mode:
authorEvan Brown <ezb@google.com>2023-09-12 08:16:03 -0700
committerCopybara-Service <copybara-worker@google.com>2023-09-12 08:16:59 -0700
commitf01b1b56de359de540c97a7898ff3011c47e2c26 (patch)
tree962949615909631158fb952f827da004b7080cdb /absl/container/CMakeLists.txt
parentf3eae68bd1d17df708f2b59a43ad7e837a616e6a (diff)
downloadabseil-f01b1b56de359de540c97a7898ff3011c47e2c26.tar.gz
abseil-f01b1b56de359de540c97a7898ff3011c47e2c26.tar.bz2
abseil-f01b1b56de359de540c97a7898ff3011c47e2c26.zip
Add a flat_hash_set_test that we use value_type member functions to read/write from value_types when we aren't allowed to memcpy them.
The motivation is to prevent a bug in small buffer optimization for swisstables. PiperOrigin-RevId: 564726325 Change-Id: Id0df5d28d65c7586428001fcb266886988cd481e
Diffstat (limited to 'absl/container/CMakeLists.txt')
-rw-r--r--absl/container/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/absl/container/CMakeLists.txt b/absl/container/CMakeLists.txt
index f3443a66..64f6965a 100644
--- a/absl/container/CMakeLists.txt
+++ b/absl/container/CMakeLists.txt
@@ -338,6 +338,8 @@ absl_cc_test(
"-DUNORDERED_SET_CXX17"
DEPS
absl::check
+ absl::config
+ absl::container_memory
absl::flat_hash_set
absl::hash_generator_testing
absl::memory