aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBenjamin Barenblat <bbaren@google.com>2024-05-08 16:14:49 -0400
committerBenjamin Barenblat <bbaren@google.com>2024-05-08 16:14:49 -0400
commit109b466e90381167a83da3eaadb0dbf72e66f210 (patch)
treed1223168297c08e67b581eb4023fd1a2b137fcb7 /debian
parent9aa75a5044aac4062db95538304d281c2b5d710b (diff)
downloadabseil-109b466e90381167a83da3eaadb0dbf72e66f210.tar.gz
abseil-109b466e90381167a83da3eaadb0dbf72e66f210.tar.bz2
abseil-109b466e90381167a83da3eaadb0dbf72e66f210.zip
Backport a patch from upstream to fix overload_test
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/overload-test-dependencies.diff27
-rw-r--r--debian/patches/series1
2 files changed, 28 insertions, 0 deletions
diff --git a/debian/patches/overload-test-dependencies.diff b/debian/patches/overload-test-dependencies.diff
new file mode 100644
index 00000000..fb843c91
--- /dev/null
+++ b/debian/patches/overload-test-dependencies.diff
@@ -0,0 +1,27 @@
+From: Benjamin Barenblat <bbaren@google.com>
+Subject: Resynchronize absl/functional/CMakeLists.txt with BUILD.bazel
+Forwarded: yes
+Applied-Upstream: https://github.com/abseil/abseil-cpp/commit/7b87d959346cab4ab9829724efee377f7fb254ed
+
+overload_test needs some extra dependencies to build when absl::variant
+is not an alias for std::variant; these dependencies are listed in
+absl/functional/BUILD.bazel but not in absl/functional/CMakeLists.txt.
+Copy dependencies from BUILD.bazel to CMakeLists.txt.
+
+The author works at Google. Upstream applied this patch as Piper
+revision 631845552 and exported it to GitHub; the Applied-Upstream URL
+above points to the exported commit.
+
+--- a/absl/functional/CMakeLists.txt
++++ b/absl/functional/CMakeLists.txt
+@@ -129,6 +129,10 @@
+ COPTS
+ ${ABSL_TEST_COPTS}
+ DEPS
++ absl::config
++ absl::overload
++ absl::string_view
+ absl::strings
++ absl::variant
+ GTest::gmock_main
+ )
diff --git a/debian/patches/series b/debian/patches/series
index 18bf90c0..ad7c41cc 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@ cordz-info-statistics-test.diff
pkg-config-directives.diff
riscv-nan-formatting.diff
riscv-rdcycle.diff
+overload-test-dependencies.diff