aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2018-03-18 23:40:28 -0700
committerAlexey Neyman <stilor@att.net>2018-04-07 12:03:17 -0700
commit355f6f03fba92c71f9ff8d2e26985d2c1b7a0a0b (patch)
tree7c8a2752a950e332e6e6583c8e17a278aa8a105f /Makefile.am
parentf45e29c5ca5c50bded67c295fb62e208365cf4d6 (diff)
downloadcrosstool-ng-355f6f03fba92c71f9ff8d2e26985d2c1b7a0a0b.tar.gz
crosstool-ng-355f6f03fba92c71f9ff8d2e26985d2c1b7a0a0b.tar.bz2
crosstool-ng-355f6f03fba92c71f9ff8d2e26985d2c1b7a0a0b.zip
Cannot ignore 'make install' with automake
Automake does not allow us to place the hooks before its generated actions, and does not allow us to check MAKECMDGOALS, and does not support a mechanism for disabling make install (such as noinst_SUBDIRS, requested a few times on automake mailing list). The only way I could preserve the current behavior is to have a GNUmakefile wrapper that will convert MAKECMDGOAL into a variable unknown to automake - which seems too convoluted a solution for the problem being solved. Hence the approach is to not override anything for --enable-local. It is now fully handled by selecting different values for CT_xxx_DIR in ct-ng.in; but at the build-system level, all the variables remain the same. We just don't support 'make install' in that case anymore; but the ct-ng in the working copy can be used after a regular 'make' (or 'make all'). Help message for --enable-local updated accordingly. Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 06c90cfc..2e98016e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,6 @@ do_subst = ( @SED@ \
-e 's,[@]docdir[@],$(docdir),g' \
-e 's,[@]pkgdatadir[@],$(pkgdatadir),g' \
-e 's,[@]pkglibexecdir[@],$(pkglibexecdir),g' \
- -e 's,[@]enable_local[@],$(enable_local),g' \
| $(SHELL) config.status --file=- )
ct-ng: ct-ng.in Makefile