aboutsummaryrefslogtreecommitdiff
path: root/packages/ltrace/0.7.3/001-avoid-libstdc++.patch
diff options
context:
space:
mode:
authorAlexey Neyman <stilor@att.net>2017-05-19 21:58:46 -0700
committerAlexey Neyman <stilor@att.net>2017-07-08 10:57:56 -0700
commite7deac3aad394325f9e6fc6fda41d34ec94a59e0 (patch)
tree6ad88362f0bfa8385a91eb494009a4646aeb74b6 /packages/ltrace/0.7.3/001-avoid-libstdc++.patch
parentb9af225f58e45c7fae7eb9d3689fe939243e7578 (diff)
downloadcrosstool-ng-e7deac3aad394325f9e6fc6fda41d34ec94a59e0.tar.gz
crosstool-ng-e7deac3aad394325f9e6fc6fda41d34ec94a59e0.tar.bz2
crosstool-ng-e7deac3aad394325f9e6fc6fda41d34ec94a59e0.zip
Switch comp.libs/tools and debug to new framework.
Signed-off-by: Alexey Neyman <stilor@att.net>
Diffstat (limited to 'packages/ltrace/0.7.3/001-avoid-libstdc++.patch')
-rw-r--r--packages/ltrace/0.7.3/001-avoid-libstdc++.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/ltrace/0.7.3/001-avoid-libstdc++.patch b/packages/ltrace/0.7.3/001-avoid-libstdc++.patch
new file mode 100644
index 00000000..9cbf5575
--- /dev/null
+++ b/packages/ltrace/0.7.3/001-avoid-libstdc++.patch
@@ -0,0 +1,43 @@
+From: Juan Cespedes <cespedes@debian.org>
+Description: avoid warning from dpkg-shlibdeps:
+ package could avoid a useless dependency if ltrace was not
+ linked against libstdc++.so.6 (it uses none of the library's symbols)
+Last-Update: 2013-12-30
+
+
+--- a/configure.ac 2013-09-17 01:04:28.000000000 +0200
++++ b/configure.ac 2013-12-30 12:24:20.000000000 +0100
+@@ -113,6 +113,15 @@
+ libstdcxx_LIBS=""])
+ AC_SUBST(libstdcxx_LIBS)
+
++if test "x$liberty_LIBS" != "x"
++then
++ libsupcxx_LIBS=""
++ libstdcxx_LIBS=""
++elif test "x$libsupcxx_LIBS" != "x"
++then
++ libstdcxx_LIBS=""
++fi
++
+
+ dnl Check security_get_boolean_active availability.
+ AC_CHECK_HEADERS(selinux/selinux.h)
+--- a/configure 2013-09-17 01:07:46.000000000 +0100
++++ b/configure 2013-12-30 12:34:23.000000000 +0100
+@@ -11826,6 +11826,15 @@
+
+
+
++if test "x$liberty_LIBS" != "x"
++then
++ libsupcxx_LIBS=""
++ libstdcxx_LIBS=""
++elif test "x$libsupcxx_LIBS" != "x"
++then
++ libstdcxx_LIBS=""
++fi
++
+
+ for ac_header in selinux/selinux.h
+ do :