aboutsummaryrefslogtreecommitdiff
path: root/packages/zstd
diff options
context:
space:
mode:
authorChris Packham <judge.packham@gmail.com>2023-12-10 11:07:33 +1300
committerChris Packham <judge.packham@gmail.com>2023-12-18 16:28:45 +1300
commit4abdebf2d9443efbe9b3e280b4b96d0a516784c0 (patch)
treebe8ea79d4fa39da4c0a12af556ac6d444649066b /packages/zstd
parentad71fdf9a1cf5d0b8d594270c990065690d67f1b (diff)
downloadcrosstool-ng-4abdebf2d9443efbe9b3e280b4b96d0a516784c0.tar.gz
crosstool-ng-4abdebf2d9443efbe9b3e280b4b96d0a516784c0.tar.bz2
crosstool-ng-4abdebf2d9443efbe9b3e280b4b96d0a516784c0.zip
zstd: Bring in upstream change for cygwin support
Bring in the upstream change that should allow building zstd on cygwin. Fixes #1974 Signed-off-by: Chris Packham <judge.packham@gmail.com>
Diffstat (limited to 'packages/zstd')
-rw-r--r--packages/zstd/1.5.5/0000-Updated-Makefiles-for-full-MSYS2.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/packages/zstd/1.5.5/0000-Updated-Makefiles-for-full-MSYS2.patch b/packages/zstd/1.5.5/0000-Updated-Makefiles-for-full-MSYS2.patch
new file mode 100644
index 00000000..de8f0de4
--- /dev/null
+++ b/packages/zstd/1.5.5/0000-Updated-Makefiles-for-full-MSYS2.patch
@@ -0,0 +1,68 @@
+From 78dbba76b81ea1d8713900b57bc5d5f5f43bf74b Mon Sep 17 00:00:00 2001
+From: Quentin Boswank <qubos@oulook.de>
+Date: Sun, 13 Aug 2023 19:44:15 +0200
+Subject: [PATCH] Updated Makefiles for full MSYS2 and Cygwin installation and
+ testing support.
+
+They are Linux-like environments under Windows and have all the tools needed to support staged installation and testing.
+
+Beware: this only affects the make build system.
+---
+ Makefile | 2 +-
+ lib/Makefile | 2 +-
+ programs/Makefile | 2 +-
+ tests/Makefile | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 72a9480aab..fd95c38901 100644
+--- a/Makefile
++++ b/Makefile
+@@ -151,7 +151,7 @@ clean:
+ #------------------------------------------------------------------------------
+ # make install is validated only for Linux, macOS, Hurd and some BSD targets
+ #------------------------------------------------------------------------------
+-ifneq (,$(filter $(shell uname),Linux Darwin GNU/kFreeBSD GNU OpenBSD FreeBSD DragonFly NetBSD MSYS_NT Haiku AIX))
++ifneq (,$(filter $(shell uname),Linux Darwin GNU/kFreeBSD GNU OpenBSD FreeBSD DragonFly NetBSD MSYS_NT CYGWIN_NT Haiku AIX))
+
+ HOST_OS = POSIX
+
+diff --git a/lib/Makefile b/lib/Makefile
+index a4cf61ab10..6d349a3b48 100644
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -249,7 +249,7 @@ clean:
+ #-----------------------------------------------------------------------------
+ # make install is validated only for below listed environments
+ #-----------------------------------------------------------------------------
+-ifneq (,$(filter $(UNAME),Linux Darwin GNU/kFreeBSD GNU OpenBSD FreeBSD NetBSD DragonFly SunOS Haiku AIX))
++ifneq (,$(filter $(UNAME),Linux Darwin GNU/kFreeBSD GNU OpenBSD FreeBSD NetBSD DragonFly SunOS Haiku AIX MSYS_NT CYGWIN_NT))
+
+ lib: libzstd.pc
+
+diff --git a/programs/Makefile b/programs/Makefile
+index 8507abef3f..be83c24933 100644
+--- a/programs/Makefile
++++ b/programs/Makefile
+@@ -346,7 +346,7 @@ include $(wildcard $(DEPFILES))
+ #-----------------------------------------------------------------------------
+ # make install is validated only for Linux, macOS, BSD, Hurd and Solaris targets
+ #-----------------------------------------------------------------------------
+-ifneq (,$(filter $(UNAME),Linux Darwin GNU/kFreeBSD GNU OpenBSD FreeBSD NetBSD DragonFly SunOS Haiku AIX))
++ifneq (,$(filter $(UNAME),Linux Darwin GNU/kFreeBSD GNU OpenBSD FreeBSD NetBSD DragonFly SunOS Haiku AIX MSYS_NT CYGWIN_NT))
+
+ HAVE_COLORNEVER = $(shell echo a | egrep --color=never a > /dev/null 2> /dev/null && echo 1 || echo 0)
+ EGREP_OPTIONS ?=
+diff --git a/tests/Makefile b/tests/Makefile
+index 778c7d6759..c31e750055 100644
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -263,7 +263,7 @@ clean:
+ # valgrind tests validated only for some posix platforms
+ #----------------------------------------------------------------------------------
+ UNAME := $(shell uname)
+-ifneq (,$(filter $(UNAME),Linux Darwin GNU/kFreeBSD GNU OpenBSD FreeBSD NetBSD DragonFly SunOS AIX))
++ifneq (,$(filter $(UNAME),Linux Darwin GNU/kFreeBSD GNU OpenBSD FreeBSD NetBSD DragonFly SunOS AIX CYGWIN_NT))
+ HOST_OS = POSIX
+
+ .PHONY: test-valgrind