aboutsummaryrefslogtreecommitdiff
path: root/packages/gcc/12.2.0/0005-Allow-default-libc-to-be-specified-to-configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/gcc/12.2.0/0005-Allow-default-libc-to-be-specified-to-configure.patch')
-rw-r--r--packages/gcc/12.2.0/0005-Allow-default-libc-to-be-specified-to-configure.patch25
1 files changed, 9 insertions, 16 deletions
diff --git a/packages/gcc/12.2.0/0005-Allow-default-libc-to-be-specified-to-configure.patch b/packages/gcc/12.2.0/0005-Allow-default-libc-to-be-specified-to-configure.patch
index 4f155f61..113a982a 100644
--- a/packages/gcc/12.2.0/0005-Allow-default-libc-to-be-specified-to-configure.patch
+++ b/packages/gcc/12.2.0/0005-Allow-default-libc-to-be-specified-to-configure.patch
@@ -15,15 +15,13 @@ and stop.
Signed-off-by: Keith Packard <keithp@keithp.com>
---
- gcc/config.gcc | 48 ++++++++++++++++++++++++++++++++++++++++--------
- gcc/configure.ac | 4 ++++
+ gcc/config.gcc | 48 ++++++++++++++++++++++++++++++++++++++++--------
+ gcc/configure.ac | 4 ++++
2 files changed, 44 insertions(+), 8 deletions(-)
-diff --git a/gcc/config.gcc b/gcc/config.gcc
-index c5064dd3766..ddab68fbf8f 100644
--- a/gcc/config.gcc
+++ b/gcc/config.gcc
-@@ -648,6 +648,8 @@ esac
+@@ -648,6 +648,8 @@
# Common C libraries.
tm_defines="$tm_defines LIBC_GLIBC=1 LIBC_UCLIBC=2 LIBC_BIONIC=3 LIBC_MUSL=4"
@@ -32,7 +30,7 @@ index c5064dd3766..ddab68fbf8f 100644
# 32-bit x86 processors supported by --with-arch=. Each processor
# MUST be separated by exactly one space.
x86_archs="athlon athlon-4 athlon-fx athlon-mp athlon-tbird \
-@@ -854,16 +856,16 @@ case ${target} in
+@@ -854,16 +856,16 @@
esac
case $target in
*-*-*android*)
@@ -53,7 +51,7 @@ index c5064dd3766..ddab68fbf8f 100644
;;
esac
# Assume that glibc or uClibc or Bionic are being used and so __cxa_atexit
-@@ -956,7 +958,8 @@ case ${target} in
+@@ -956,7 +958,8 @@
case ${enable_threads} in
"" | yes | posix) thread_file='posix' ;;
esac
@@ -63,7 +61,7 @@ index c5064dd3766..ddab68fbf8f 100644
;;
*-*-rdos*)
use_gcc_stdint=wrap
-@@ -1606,13 +1609,13 @@ csky-*-*)
+@@ -1606,13 +1609,13 @@
case ${target} in
csky-*-linux-gnu*)
@@ -79,7 +77,7 @@ index c5064dd3766..ddab68fbf8f 100644
default_use_cxa_atexit=no
;;
*)
-@@ -3065,7 +3068,7 @@ powerpc*-wrs-vxworks7r*)
+@@ -3065,7 +3068,7 @@
tmake_file="${tmake_file} t-linux rs6000/t-linux64 rs6000/t-fprules rs6000/t-ppccomm"
tmake_file="${tmake_file} rs6000/t-vxworks"
@@ -88,7 +86,7 @@ index c5064dd3766..ddab68fbf8f 100644
extra_objs="$extra_objs linux.o rs6000-linux.o"
;;
powerpc-wrs-vxworks*)
-@@ -5915,3 +5918,32 @@ i[34567]86-*-* | x86_64-*-*)
+@@ -5915,3 +5918,32 @@
fi
;;
esac
@@ -121,11 +119,9 @@ index c5064dd3766..ddab68fbf8f 100644
+ tm_defines="$tm_defines DEFAULT_LIBC=$default_libc"
+ ;;
+esac
-diff --git a/gcc/configure.ac b/gcc/configure.ac
-index 23bee7010a3..4fd41993b58 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
-@@ -2481,6 +2481,10 @@ if { { test x$host != x$target && test "x$with_sysroot" = x ; } ||
+@@ -2481,6 +2481,10 @@
fi
AC_SUBST(inhibit_libc)
@@ -136,6 +132,3 @@ index 23bee7010a3..4fd41993b58 100644
# When building gcc with a cross-compiler, we need to adjust things so
# that the generator programs are still built with the native compiler.
# Also, we cannot run fixincludes.
---
-2.39.0
-