aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFlavio Cruz <flaviocruz@gmail.com>2023-01-29 01:09:00 -0500
committerSamuel Thibault <samuel.thibault@ens-lyon.org>2023-01-29 16:19:24 +0100
commit5557f2ca9d526874a7fc499c1068ea93628a40fa (patch)
tree62b95571fecd6508c804940be4888c1f4391309a /Makefile.am
parenta8fbf3737be9a6f5fd1d87765072292d54e54aac (diff)
downloadgnumach-5557f2ca9d526874a7fc499c1068ea93628a40fa.tar.gz
gnumach-5557f2ca9d526874a7fc499c1068ea93628a40fa.tar.bz2
gnumach-5557f2ca9d526874a7fc499c1068ea93628a40fa.zip
Enable -Wmissing-prototypes.
* Makefile.am: enable -Wmissing-prototypes * ddb/db_inout.h: Prototype kdb_kintr for entering into DDB. * ddb/db_mp.c Include ddb/db_input.h to get kdb_kintr. * i386/i386at/kd.h: Include ddb/input.h to get kdb_kintr. * linux/Makefrag.am: Disable some of the new warnings for linux drivers, otherwise we will get more and more noise. Message-Id: <Y9YNfNaYSsZJFST5@mercury.tail36e24.ts.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c52241e9..10d030b8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,7 +61,7 @@ AM_CCASFLAGS += \
# Yes, this makes the eyes hurt. But perhaps someone will finally take care of
# all that scruffy Mach code... Also see <http://savannah.gnu.org/task/?5726>.
AM_CFLAGS += \
- -Wall -Wstrict-prototypes -Wold-style-definition
+ -Wall -Wstrict-prototypes -Wold-style-definition -Wmissing-prototypes
# We need the GNU-style inline
AM_CFLAGS += \